1

I just installed Nginx 1.6.0, MySQL, PHP-FPM 5.5.9 and phpMyAdmin on my Ubuntu 14.04 LTS 64-bit server. When I go to domain.tld/phpmyadmin I end up at a blank page but when I view source, I can see the HTML login forms, javascripts and everything else, although the page is blank.

I've followed this guide and normal PHP scripts work. A simple PHP script that echoes "hello" works perfectly fine. There are no errors in /var/log/nginx/error.log or access.log. Here's my nginx configuration:

server {
        listen 8081 default_server;
        #listen [::]:80 default_server ipv6only=on;

        root /usr/share/nginx/html;
        index index.php index.html index.htm;

        # Make site accessible from http://localhost/
        server_name localhost;

        location / {
                # First attempt to serve request as file, then
                # as directory, then fall back to displaying a 404.
                try_files $uri $uri/ =404;
                # Uncomment to enable naxsi on this location
                # include /etc/nginx/naxsi.rules
        }

        # Only for nginx-naxsi used with nginx-naxsi-ui : process denied requests
        #location /RequestDenied {
        #       proxy_pass http://127.0.0.1:8080;
        #}

        #error_page 404 /404.html;

        # redirect server error pages to the static page /50x.html
        #
        #error_page 500 502 503 504 /50x.html;
        #location = /50x.html {
        #       root /usr/share/nginx/html;
        #}

        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~ \.php$ {
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini

                # With php5-cgi alone:
                #fastcgi_pass 127.0.0.1:9000;
                # With php5-fpm:
                fastcgi_pass unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                include fastcgi_params;
        }

        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        #location ~ /\.ht {
        #       deny all;
        #}
}

Just tell me if you need more information. As stated, the error.log is blank.

  • Exactly what appears in the HTML source? – Michael Hampton Aug 7 '14 at 22:04
  • There's a lot, but no errors. I see the login form. – Sven Aug 7 '14 at 22:21
  • 1
    Yeah, but I can't see it! – Michael Hampton Aug 7 '14 at 22:21
2

Your HTML head inexplicably contains the following:

<style>html{display: none;}</style>

This does exactly what you think it does: it turns off display for the entire document.

If you didn't put that in there, seek help from whoever did.

  • Odd, this is a fresh installation made a few minutes ago. – Sven Aug 7 '14 at 22:30
  • @TomJordell did you ever find a solution to this? confirmed that this is happening on my fresh installations of phpmyadmin. driving me mad! – RapidWebs Oct 10 '14 at 16:24
0

I had the same issue; changing the $cfg['AllowThirdPartyFraming'] in config fixed the problem. It is was to js disabled on browser. See https://github.com/zixtor/phpmyadmin/commit/c1e8834e44f110aca736e49a6def3e4c11015879

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.