0

I was trying to virtualize a opensuse server and discovered that GRUB2 is not supported by VMWare, at least without some fiddling. I went into Yast and changed the bootloader from GRUB to GRUB2, and told the machine to convert the existing configuration.

The machine will no longer boot, when it come up GRUB loads without errors and I get stuck at the grub prompt:

grub>

I can execute grub commands, and using the rescue disk I can perform the following and even get back into yast, but nothing I have tried has worked. Tried going back to GRUB2 but grub still loads.

Here is how I access the system:

  1. Boot to rescue system
  2. mount /dev/sda1 /mnt
  3. mount --bind /dev /mnt/dev
  4. mount --bind /sys /mnt/sys
  5. mount --bind /proc /mnt/proc
  6. chroot /mnt

From here I can do everything on the system as usual. My system layout is

/

/home

/swap

  • What's the output of legacy GRUB? Have you reinstalled GRUB to the MBR of your virtual machine? – Marc Stürmer Aug 8 '14 at 14:19
  • This is on a physical machine. I believe grub is installed on the MBR. the machine boots and says: Gnu GRUB verion 0.97 (639K lower / 1034712K upper memory) [Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists the possible completions of a device/filename. ] grub> – chongo2002 Aug 8 '14 at 14:41
0

Well, you got GRUB installed correctly and booting up correctly as well.

What you haven't got yet is configured a menu for GRUB. That's why you end up on the GRUB command line with GRUB waiting for you to tell it what to boot how and where.

Here's a nice tutorial which covers many aspects of installing legacy GRUB:

https://wiki.archlinux.org/index.php/GRUB_Legacy

Check it out.

  • that was it, I went back into rescue and the grub menu.lst was barebones, here is what I added: title OpenSuse 13.1 root (hd0,2) kernel /boot/vmlinuz root=/dev/sda3 ro initrd /boot/initrd – chongo2002 Aug 8 '14 at 21:23

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.