0

I got ruby installed system-wide by doing:

\curl -sSL https://get.rvm.io | sudo bash -s stable

and then:

sudo /usr/local/rvm/bin/rvm install 2.0.0

I'm still not positive that was actually correct, but it seems to have worked. It created an rvm group. I've added my user account to it, and re-logged in. Now I need to bundle install the gems for my Rails app. This is as close as I can get:

david@excelsior:/data/webapps/accountability$ sudo /usr/local/rvm/gems/ruby-2.0.0-p481@global/bin/bundle
/usr/bin/env: ruby_executable_hooks: No such file or directory

In the past, I've just done all of this stuff as root, but the rvm website spends a lot of time telling me that this (and rvmsudo) is "wrong" for system-wide operations. So I want to try doing it "right" this time, but I can't find where they've indicated how I should be doing it. It would seem that this simple operation would be front-and-center. Maybe I'm just blind?

  • My goal here is to deploy multiple Rails apps in, say, /data/webapps, all with their own versions of Ruby and various gems, and serve those apps with a standard Apache/Passenger install. – David Krider Aug 9 '14 at 12:35
1

you do not need to use sudo, it should be enough to be in rvm group, just make sure you are in it with id.

as for the bundle command, I assume you do not rvm use 2.0.0-p481 before running the bundle, so instead of the bin/bundle you should be running wrapper which takes care of loading proper ruby environment for you:

/usr/local/rvm/wrappers/ruby-2.0.0-p481/bundle
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.