3

I appear to have the problem described here:

"After cloning and syspreping [...] VMs running Windows [...], I was not able to connect to the cloned servers by Remote Desktop. After troubleshooting the steps below, I noticed the the RDP-TCP listener was not listening on a network adapter. (I am certain it occurred while cloning /VMTools update)"

enter link description here

Alas, I cannot use the proposed solution:

"Open Remote Desktop Session Host Configuration[...]"

The VM in question is running Server Core.

Is there a way to force Remote Desktop to listen on an adapter using the command line interface? Disabling and enabling Remote Desktop in sconfig.exe doesn't do it.

2
  • Is this Server 2008 R2, 2012, or 2012 R2?
    – briantist
    Aug 10, 2014 at 2:49
  • This is 2012 R2, but I need/want to know generally. Aug 11, 2014 at 7:36

1 Answer 1

1

I asked in a comment about your OS, but your link specifically refers to 2008 R2 so I will assume that for now.

In that case, I would recommend you open Remote Desktop Session Configuration on another machine, then right click on RD Session Host Configuration and choose Connect to Remote Desktop Session Host Server to connect to the machine running core.

Like so many things in core on 2008 R2, having a machine with a GUI is probably the easiest way to achieve this.

If that doesn't work, or you don't have access to another machine with the tool, check this registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

I noticed that the the LanAdapter value changed when I changed the setting you're interested in. I only have 1 adapter on my server. When the setting was set to All network adapters configured with this protocol the registry value was 0. When I changed the setting to explicitly use the one adapter I have, the value changed to 1.

So perhaps changing this to 0 will allow it to work after when clone the VM, after which you could lock it down so to speak if you feel it's necessary.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.