-1

i'm trying to ping mail.example.com but failed. base on my below zone configuration.

Did I configure anything wrong?

$TTL 604800 ; 1 week
@   IN  SOA serverad.example.com.   root.example.com. (
                232       ; serial
                604800     ; refresh (1 week)
                86400      ; retry (1 day)
                2419200    ; expire (4 weeks)
                604800     ; minimum (1 week)
                )
IN  NS  serverad.example.com.
serverad        IN      A   172.17.5.121
121     IN  PTR serverad.example.com.

mail    IN  A   172.17.5.22
22      IN  PTR mail.example.com.
12
  • 1
    Your PTR records don't belong in your forward zone; you should have a separate reverse zone for those. Could you clarify what you mean when you say the ping doesn't work? Does the name resolution fail, or does the name resolve to the IP and the ping results in no reply?
    – briantist
    Commented Aug 10, 2014 at 4:00
  • actually i wan to ping "mail.example.com" but it said unknown host. Commented Aug 10, 2014 at 4:06
  • i thought it should reply 172.17.5.22. i'm just started to learn dns zone. but, according to tutorial. should work. Commented Aug 10, 2014 at 4:07
  • Where are you pinging from? Does that machine use the BIND server as a DNS server?
    – briantist
    Commented Aug 10, 2014 at 4:10
  • ya. i'm using this bind server as DNS server. actually i tried on my local bind server, it reply the same error message. Commented Aug 10, 2014 at 4:12

1 Answer 1

0

i found out why, my zone has key in wrong,and my zone is already exist in samba4 dynamic create zone,i need to use samba-tool dns add or dns management tools in window

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .