0

I would like to prevent Putty from setting the server terminal length so as to avoid the dreaded --More-- prompt in Cisco IOS. Please do not tell me to set length 0 in line config mode because this does not work with Putty. terminal length 0 in exec mode does work but this must be executed every logon.

The problem appears to be that Putty is setting the terminal length on connect, because I can control the length by setting the Putty window size. When I resize the Putty window during the session the terminal length remains where it was.

  • Have you tried putting "terminal lenght 0" in Connection - SSH - Remote command? – Guido Vaccarella Aug 11 '14 at 16:07
  • @GuidoVaccarella, no there's another command there. Can I add more than one? – ThomasMcLeod Aug 11 '14 at 16:14
  • @GuidoVaccarella, actually that causes the Putty windows to immediately close – ThomasMcLeod Aug 11 '14 at 16:20
1

I ran into the same issue with a standard OpenSSH client on my Fedora system today.

The "-T" option helped here. The same is available for putty. Disable pseudo-terminal allocation

0

This has nothing to do with Putty.

When changing the lenght of the terminal, you are changing it only for your session.

If you want to make this change system wide and permanent, you need to change the VTY settings.

line vty 0 4
length 0

Obviously if you want this to stick if the switch or router reboots, you need to do a write mem

  • As I said in the original question, this does not work with Putty. Putty is explicitly setting the terminal length to it's window size. – ThomasMcLeod Aug 11 '14 at 18:05
  • Re-read my answer. In your question your are changing the terminal length, not the vty line length. – Alex Aug 11 '14 at 18:12
  • see above: "Please do not tell me to set length 0 in line config mode because this does not work with Putty." – ThomasMcLeod Aug 11 '14 at 18:52
  • Well, the only thing I can tell you is that it does work with Putty. Since you seem to know what we should and shouldn't answer then I don't see the point of asking the question in the first place. – Alex Aug 11 '14 at 19:02
  • What protocol are you using with Putty to connect to the cisco? – ThomasMcLeod Aug 11 '14 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.