0

I've just installed Mac OS X Yosemite fresh. I configured Apache and chmodded "users/user/Sites" to 755. When I hit localhost I receive a 403 Forbidden "You don't have permission to access / on this server". The same thing occurs with any other sites I add to my hosts file.

I tried configuring user directories following help from this post. The guys on this MacRumors thread know there is an Apache issue, but didn't offer a lot of suggestions.

My directory permissions look like this

drwxr-xr-x  29 root             wheel  1054 Aug 11 07:30 /
drwxr-xr-x   6 root             admin   204 Aug 11 07:29 /Users/
drwxr-xr-x+ 26 zachshallbetter  staff   884 Aug 11 11:57 /Users/zachshallbetter/
 0: group:everyone deny delete
drwxr-xr-x   5 zachshallbetter  staff   170 Aug 11 10:16 /Users/zachshallbetter/Sites

Can anyone offer any suggestions or help? Here are links to my hosts and httpd.conf files and error logs for reference.

-1

You've got two problems:

  1. Your doc roots for dummy-host.example.com and dummy-host2.example.com dont exist!

  2. You enabled authz, and presumably have some sort of auth requirement in your vhost configs, that is denying you access.

Fix both, and you should be good to go.

I.E. Make sure the directory that holds your documents, and the documents themselves, actually exist so apache can serve them up. AND, get rid of any auth setup that you arent actually using. If you are not using authz, disable it.

  • Thanks for the help. So I need to add 192.168.1.1 www.dummy-host.example.com to my host file? I thought 127.0.0.1 localhost served that same purpose. Or are you suggesting something else? – Zach Shallbetter Aug 11 '14 at 19:09
  • Also, when I disable the authz items and run a configtest I receive the error: AH00526: Syntax error on line 221 of /private/etc/apache2/httpd.conf: Invalid command 'Require', perhaps misspelled or defined by a module not included in the server configuration and Apache no longer starts – Zach Shallbetter Aug 11 '14 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.