I created three new partitions, but after a reboot, the system is being dropped to a shell:

/dev/mapper/group-newpartition: clean, 11/655360 files, 276620/2621440 blocks [FAILED]

An error occurred during the file system check.
Dropping you to a shell; the system will reboot
Give root password for maintenance.

I tried to fix the disk error with fsck(), but the result status code is 0x4. I tried to reverse what I changed in /etc/fstab so that the system didn't check the partition while booting. But the shell the system being dropped to was a read only file system. I tried to access through the single user mode, but the result was the same. How to fix the problem?

  • 1
    Why would you consider attempting to modify a seriously damaged disk that failed an fsck? – mdpc Aug 12 '14 at 2:02
  • This downvote because you asked a question, didn't even made it ready (see the end), and then disappeared without any reaction. You let others work for nothing. – peterh - Reinstate Monica Aug 12 '14 at 8:38
  • I check the post when I am available online. I asked 16 hours ago. And revisit the post is the first thing I do this morning when I am before a computer. – Purres Aug 12 '14 at 17:51

The reason you are in read-only mode is that: a) Your file system was found to be damaged, then b) Your OS tried to fix it at boot, but failed, so c) Dropped you into a read-only shell so that you can extract and backup your files without modifying original file system hence preventing you from damaging it further.

If I were you, I would try to fix the problem first. However, if you do insist, you can remount your filesystem with -o loop,rw like

mount -t ext4 /dev/sda1 /mnt/sysimage -o loop,rw

where /mnt/sysimage is your mount point.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.