I have a merge publishing subscriber topology of SQL 2008 -> SQL 2000 -> MS Access 2003. In one database at the SQL 2008 level, I have an updateable publication (called catalog) that is unfiltered, subscribed to by the SQL 2000 server, and then republished to the MS Access client. I can make insert/updates at the MS Access subscriber and they flow nicely up to the SQL 2008 server. In another db on SQL 2008, I have a couple of publications. The first publication has a static filter based on a region value. The other publication is an unfiltered publication of orders and lines. Both of these publications are subscribed to by the SQL 2000 machine to a db separate from the catalog publication. At the SQL 2000 level, I create filtered publications per user that pull from the filtered tables and then joins to the orders tables. I can create the MSAccess publications and synch them down fine. The issue is when I make changes in any of the filtered tables. I see that the update hits the SQL 2000 server, but it doesn't flow up to the SQL 2008 server. I tried a dummy update and then the changes flowed to the SQL 2008 machine. Any ideas why changes that are uploaded to the filtered tables in SQL 2000 are not propagating to the SQL 2008 machine?


After opening a case with MS, it was determined a bug is induced in a publishing subscriber/republisher topology when setting column_tracking = true. In addition, I had created a statically filtered publication at the top-level publisher that didn't seem to help. The issue was that the MS Access subscriber would upload changes to the republisher, but with an art_nick/tablenick of 0. The MS rep also said this occurred with SQL CE. At any rate, the agent between the republisher and the publisher would ignore the record(s) in msmerge_contents because the tablenick was not set. To get around this, I removed the statically filtered publication at the publisher level and changed all publications to use row level tracking. Once I did this, all changes from the subscriber propagated to the publisher as expected.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.