2

I get this error when I try and run 'yum-complete-transaction' in shell:

[root@namesvr ~]# yum-complete-transaction
Loaded plugins: fastestmirror
mirror speeds from cached hostfile
Loading mirror speeds from cached hostfile
There are 1 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 35 elements left to run
Package 1:httpd-tools-2.2.15-31.el6.centos.vm.x86_64 already installed and latest        version
Package 2:mod_ssl-2.2.15-31.el6.centos.vm.x86_64 already installed and latest version
Package wbm-virtual-server-4.09.gpl-1.noarch already installed and latest version
--> Running transaction check
---> Package GeoIP.x86_64 0:1.4.8-1.el6 will be updated
---> Package GeoIP.x86_64 0:1.5.1-5.el6 will be an update
---> Package ca-certificates.noarch 0:2013.1.95-65.1.el6_5 will be updated
---> Package ca-certificates.noarch 0:2014.1.98-65.0.el6_5 will be an update
---> Package e2fsprogs.x86_64 0:1.41.12-18.el6 will be updated
---> Package e2fsprogs.x86_64 0:1.41.12-18.el6_5.1 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.41.12-18.el6 will be updated
---> Package e2fsprogs-libs.x86_64 0:1.41.12-18.el6_5.1 will be an update
---> Package grub.x86_64 1:0.97-83.el6 will be updated
---> Package grub.x86_64 1:0.97-84.el6_5 will be an update
---> Package httpd.x86_64 1:2.2.15-29.el6.vm.1 will be updated
---> Package httpd.x86_64 1:2.2.15-31.el6.centos.vm will be an update
---> Package initscripts.x86_64 0:9.03.40-2.el6.centos.1 will be erased
--> Processing Dependency: initscripts for package: postgresql-8.4.20-1.el6_5.x86_64
--> Processing Dependency: initscripts for package: postgresql-8.4.20-1.el6_5.x86_64
--> Processing Dependency: initscripts >= 8.83-1 for package: plymouth-0.8.3-27.el6.centos.x86_64
--> Processing Dependency: initscripts >= 6.75 for package: 12:dhclient-4.1.1-38.P1.el6.centos.x86_64
--> Processing Dependency: initscripts for package: 1:net-snmp-5.5-49.el6_5.1.x86_64
--> Processing Dependency: initscripts for package: mysql-server-5.1.73-3.el6_5.x86_64
--> Processing Dependency: initscripts for package: mysql-server-5.1.73-3.el6_5.x86_64
--> Processing Dependency: initscripts for package: 1:dovecot-2.0.9-7.el6_5.1.x86_64
--> Processing Dependency: initscripts for package: 1:dovecot-2.0.9-7.el6_5.1.x86_64
--> Processing Dependency: initscripts for package: 1:dovecot-2.0.9-7.el6_5.1.x86_64
--> Processing Dependency: initscripts for package: 1:quota-3.17-21.el6_5.x86_64
--> Processing Dependency: initscripts >= 6.38 for package: 1:quota-3.17-21.el6_5.x86_64
--> Processing Dependency: initscripts >= 8.36 for package: 1:httpd-2.2.15-31.el6.centos.vm.x86_64
--> Processing Dependency: initscripts >= 8.63-1 for package: dracut-004-336.el6_5.2.noarch
--> Processing Dependency: initscripts >= 5.20 for package: openssh-5.3p1-94.el6.x86_64
-> Processing Dependency: initscripts for package: postgresql-server-8.4.20-1.el6_5.x86_64
--> Processing Dependency: initscripts for package: postgresql-server-8.4.20-1.el6_5.x86_64
--> Processing Dependency: initscripts >= 8.11.1-1 for package: kernel-2.6.32-431.23.3.el6.x86_64
--> Processing Dependency: initscripts >= 5.86-1 for package: kbd-1.15-11.el6.x86_64
--> Processing Dependency: initscripts for package: cloud-init-0.7.4-2.el6.noarch
---> Package kernel.x86_64 0:2.6.32-431.el6 will be erased
--> Package kernel.x86_64 0:2.6.32-431.23.3.el6 will be installed
---> Package kernel-firmware.noarch 0:2.6.32-431.20.3.el6 will be updated
---> Package kernel-firmware.noarch 0:2.6.32-431.23.3.el6 will be an update
---> Package kernel-headers.x86_64 0:2.6.32-431.20.3.el6 will be updated
---> Package kernel-headers.x86_64 0:2.6.32-431.23.3.el6 will be an update
---> Package libcom_err.x86_64 0:1.41.12-18.el6 will be erased
---> Package libcom_err-devel.x86_64 0:1.41.12-18.el6 will be updated
---> Package libcom_err-devel.x86_64 0:1.41.12-18.el6_5.1 will be an update
---> Package libss.x86_64 0:1.41.12-18.el6 will be erased
---> Package mod_ssl.x86_64 2:2.2.15-29.el6.vm.1 will be erased
---> Package nspr.x86_64 0:4.10.2-1.el6_5 will be erased
---> Package nss.x86_64 0:3.15.3-6.el6_5 will be erased
---> Package nss-sysinit.x86_64 0:3.15.3-6.el6_5 will be erased
---> Package nss-tools.x86_64 0:3.15.3-6.el6_5 will be updated
---> Package nss-tools.x86_64 0:3.16.1-4.el6_5 will be an update
--> Finished Dependency Resolution
Error: Package: kernel-2.6.32-431.23.3.el6.x86_64 (updates)
       Requires: dracut-kernel >= 002-18.git413bcf78
       Removing: dracut-kernel-004-336.el6_5.2.noarch (@updates)
           dracut-kernel = 004-336.el6_5.2
       Available: dracut-kernel-004-335.el6.noarch (base)
           dracut-kernel = 004-335.el6
       Available: dracut-kernel-004-336.el6.noarch (updates)
           dracut-kernel = 004-336.el6
 You could try using --skip-broken to work around the problem
** Found 19 pre-existing rpmdb problem(s), 'yum check' output follows:
audit-2.2-4.el6_5.x86_64 is a duplicate with audit-2.2-2.el6.x86_64
audit-libs-2.2-4.el6_5.x86_64 is a duplicate with audit-libs-2.2-2.el6.x86_64
glibc-2.12-1.132.el6_5.2.x86_64 is a duplicate with glibc-2.12-1.132.el6_5.1.x86_64
glibc-common-2.12-1.132.el6_5.2.x86_64 is a duplicate with glibc-common-2.12-    1.132.el6_5.1.x86_64
glibc-devel-2.12-1.132.el6_5.2.x86_64 is a duplicate with glibc-devel-2.12-    1.132.el6_5.1.x86_64
glibc-devel-2.12-1.132.el6_5.2.x86_64 has missing requires of glibc-headers = ('0', '2.12', '1.132.el6_5.2')
gnutls-2.8.5-14.el6_5.x86_64 is a duplicate with gnutls-2.8.5-13.el6_5.x86_64
1:httpd-2.2.15-29.el6.vm.1.x86_64 has missing requires of httpd-tools = ('1', '2.2.15', '29.el6.vm.1')
libcom_err-1.41.12-18.el6_5.1.x86_64 is a duplicate with libcom_err-1.41.12-18.el6.x86_64
libcurl-7.19.7-37.el6_5.3.x86_64 is a duplicate with libcurl-7.19.7-37.el6_4.x86_64
libss-1.41.12-18.el6_5.1.x86_64 is a duplicate with libss-1.41.12-18.el6.x86_64
libtasn1-2.3-6.el6_5.x86_64 is a duplicate with libtasn1-2.3-3.el6_2.1.x86_64
2:mod_ssl-2.2.15-31.el6.centos.vm.x86_64 is a duplicate with 2:mod_ssl-2.2.15-29.el6.vm.1.x86_64
2:mod_ssl-2.2.15-31.el6.centos.vm.x86_64 has missing requires of httpd = ('1', '2.2.15', '31.el6.centos.vm')
nspr-4.10.6-1.el6_5.x86_64 is a duplicate with nspr-4.10.2-1.el6_5.x86_64
nss-3.16.1-4.el6_5.x86_64 is a duplicate with nss-3.15.3-6.el6_5.x86_64
nss-sysinit-3.16.1-4.el6_5.x86_64 is a duplicate with nss-sysinit-3.15.3-6.el6_5.x86_64
nss-util-3.16.1-1.el6_5.x86_64 is a duplicate with nss-util-3.15.3-1.el6_5.x86_64
openssl-1.0.1e-16.el6_5.14.x86_64 is a duplicate with openssl-1.0.1e-16.el6_5.7.x86_64

Doing a 'package-cleanup --problems' results in a similar problem. Please help.

3

I have solved such problems in the past with package-cleanup tool (install "yum-utils") with --cleandupes and then repeat yum check and yum-complete-transaction.

  • I get an error when I try and run package-cleanup -cleanupes Error: Trying to remove "yum", which is protected You could try using --skip-broken to work around the problem ** Found 18 pre-existing rpmdb problem(s), 'yum check' output follows: – keitex Aug 12 '14 at 14:46
  • It looks like you have a serious RPM breakage and need to be extremely careful if you don't understand how RPM works (which is OK). First, you can add --skip-broken like it's suggested to it fixes what else it can. Then run yum check and take a note of which packages are conflicting. Now comes the critical part: download the latest versions of those packages (the ones that yum was supposed to upgrade) and run rpm --force -Uvh *.rpm on them so rpm forcibly install them. Run yum check again and package-cleanup . – Giovanni Tirloni Aug 12 '14 at 15:01
  • Still not working.. will not let me install individual rpms. [root@namesvr tmp]# rpm --force -Uvh glibc-common-2.12-1.132.el6_5.2.x86_64.rpm warning: glibc-common-2.12-1.132.el6_5.2.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 192a7d7d: NOKEY error: Failed dependencies: glibc-common = 2.12-1.132.el6_5.1 is needed by (installed) glibc-2.12-1.132.el6_5.1.x86_64 – keitex Aug 12 '14 at 15:50
0

I've managed to fix it by running 'package-cleanup --cleandupes' several times and then running yum update. All working okay now. Cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.