4

I'm trying to send email to a domain that has two MX records. The higher priority record is IPv4 and the 2nd is IPv6.

Exchange gives me a delivery is delayed message in my inbox after I've tried to send the email.

A look at the connectivity logs shows

Established connection to XXXXX (the correct IPv4 IP)
Failed connection to XXXX (the correct IPv6 IP)
Retry

Despite establishing the connection to the IPv4 address it doesn't start the message delivery. If I send the email via telnet from the transport server to the IPv4 address it is successful.

With other domains it would just deliver the email over the IPv4 IP. I'm sending to many other domains with a similar MX configuration without a problem.

My firewall is an ASA and my public IPs are IPv4. The transport server is Win 2008 x64.

21
  • Maybe the other machine has greylisting in action? Aug 12 '14 at 19:42
  • 1
    Two things come to mind...first is "Use the External DNS Lookup on the transport server” checked on the Send Connector? Second, is ipv6 disabled on your Exchange 2007 server or enabled? I ask because it sounds like IPv6 is enabled and will take precedence over an IPv4 connection in Exchange if it's available. You can create a specific send connector for this IPv4 address and domain if you wish and that would work too and prove the issue.
    – TheCleaner
    Aug 12 '14 at 21:17
  • 2
    That leads to the question: If you don't have IPv6, why does your Exchange server think you do? Has IPv6 been partially configured on your network? Aug 15 '14 at 19:39
  • 1
    @PHLiGHT I don't think your problem is related to IPv6 connectivity. I think your problem is related to the IPv4 communication between you and that server. You need to look at a packet capture to see what is the difference between the failed attempt to deliver over IPv4 by the mail server and the successful attempt at doing the same with telnet.
    – kasperd
    Aug 28 '14 at 16:17
  • 1
    I would not recommend changing the v4/v6 preference since you already show that you are trying v4 first. There are VERY few circumstances that will be solved by changing that and this should not have that effect.
    – Jim B
    Aug 28 '14 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.