1

I am trying to set up a basic MDT solution. I have set one up in the past at a previous job and it worked flawlessly, however here I'm running into a problem and am having no luck getting around it.

I've installed Windows Server 2012 and MDT 2013, along with adding on the WDS role. I haven't configured much outside of the defaults for WDS, basically just set PXE response to respond to all clients (and unchecked admin approval). This machine does not run a DHCP server. I looked on the DHCP scope of our DHCP server, it shows options 66/67 checked and the server name of the WDS server is in there as well. I didn't add this but I assume it was put on during the install process (I believe I had to manually make some adjustments at my old job for this).

The PC I have is a Dell Optiplex 755. I have enabled the onbard NIC w/PXE boot option in BIOS and attempted to boot. I get a "TFTP...." error but nothing offering out a DHCP address like I'm used to. In my previous job it pretty much worked right out of the box. I've verified that PortFast is enabled on the port and I've tried a couple different PCs (but both are the same model, only model I have to work with). No matter what, I get the same error.

The subnet the PC is in is a different subnet than where the WDS server is sitting, but there are IP helper statements on the switch and the PCs can get regular DHCP addresses just fine from the DHCP server, just doesn't seem to get offered out a PXE boot option.

I don't know if the problem is a configuration with the server or the PC itself...but after a few days of Googling I'm running out of ideas. Does anyone have a good idea of something it may be?

  • Wild guess: TFTP isn't firewalled off, is it? – Katherine Villyard Aug 14 '14 at 22:40
  • Good guess, but I turned the firewall off on the WDS server before starting specifically to avoid any potential issues like this. It's strange too because when I had done this before, I never remember it saying TFTP anything, just showing the DHCP spinning/searching "dots"...and then getting an IP address. With this, it shows the machine as getting an IP address from the DHCP server, but just says "TFTP..." for a bit, then gives the error "PXE-E32: TFTP open timeout". I'm not specifically using a TFTP server for this, but it may be using TFTP on the backend for the file copy down (cont.) – Moman10 Aug 15 '14 at 13:05
  • When I looked this error up, it says causes would be that there is not TFTP server for it to get a response from (of course), the server is not running (seems obvious haha) and TFTP and DHCP/BOOTP services are running on different machines, but the next-server (066) option was not specified. Looking at our DHCP server, option 066 is selected and the FQDN of the WDS server is in there. – Moman10 Aug 15 '14 at 13:06
  • Just to be as specific as possible, when I boot the PC it shows Initializing Intel Boot Agent, PXE 2.1 Build 086, Copyright stuff, then Client MAC Addr, DHCP / spins for just a second, then comes back with Client IP address, Mask, DHCP server IP, Gateway, then the PXE-E32 timeout error. Tries a few times and eventually goes onto the next boot option. So it appears it's getting an address just fine from DHCP, just not moving on to the next step. – Moman10 Aug 15 '14 at 13:14
1

Well, I ended up figuring out what the problem was (but now on to a new problem, will post a new question). It turns out the Admin before me attempted to setup MDT in the past apparently, and there was a name stuck in DHCP/DNS exactly as I named the new server. So once I deleted it, it boots to PXE just fine!

Thanks you all for your help! I'll be posting a new question shortly on problems accessing the DeploymentShare$. It's frustrating that there are so many hurdles, previously it was a piece of cake to setup!

Thanks again.

0

I have not had any luck with having my WDS (PXE) server separate from the DHCP server. I have always had to have it on the same server.

Add the DHCP role to the server and configure WDS's options to configure DHCP automatically and to not listen on DHCP ports.

Also this might just fix your issue without having DHCP on the same box:

Have you tried configuring these options?

Example configuration of WDS's DHCP options

These are my options. I have the DHCP server on the same box as my WDS/MDT system.

  • In the past I know we didn't have ours setup with DHCP, but it was a totally different network, this one is many times more complex, maybe something in the complexity is preventing it. – Moman10 Aug 15 '14 at 13:11
  • Did you try putting the DHCP function on the same server that WDS is installed on? – Elliot Labs LLC Aug 15 '14 at 19:55
  • There is no requirement to run DHCP on the same server as WDS and I would never recommend that. – MDMarra Aug 18 '14 at 18:27
  • That is true but that is the only way that it has worked for me. I would also not recommend running them on the same server but if it works for you (as in my case) then do it. – Elliot Labs LLC Aug 18 '14 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.