1

We've moved from a 6 year old server to a brand new dual hex core windows server expecting to see marked improvements with page load times - we are not seeing the page load times we had expected. I suspect there are some server tweaks we may need to make so feel free to make suggestions here. What we are clearlly having problems with is the c:\apache\bin\zlib1.dll. The original version of the file we used was 1.2.7.0 and downgraded it to 1.2.3 and see some improvements but the file is still having problem. According to the Event Viewer, Apache will crash every 2-5 minutes, and restart. We believe this constant restarting of Apache is causing contributing to the increased page load times. I've googled the topic but not finding much help.

Here is just one of many "Error" being recorded in the Event Viewer:

Faulting application name: httpd.exe, version: 2.2.25.0, time stamp: 0x51dd049c Faulting module name: zlib1.dll, version: 1.2.3.0, time stamp: 0x4790446a Exception code: 0xc0000005 Fault offset: 0x00002bad Faulting process id: 0x2834 Faulting application start time: 0x01cfb8aa2d701ade Faulting application path: C:\Apache2\bin\httpd.exe Faulting module path: C:\Apache2\bin\zlib1.dll Report Id: 711dd079-249d-11e4-a080-002590f28d7e

...Here is just one of many "Information" being recorded in the Event Viewer:
There are two of these for every one error above.

Fault bucket, type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: httpd.exe
P2: 2.2.25.0
P3: 51dd049c
P4: zlib1.dll
P5: 1.2.3.0
P6: 4790446a
P7: c0000005
P8: 00002bad
P9: 
P10: 

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_httpd.exe_256685416edd7cac84481b267459aabb3b2eed47_18295e72

Analysis symbol: 
Rechecking for solution: 0
Report Id: 0e85325a-24a2-11e4-a080-002590f28d7e
Report Status: 0

Our Stack is:

Server: Windows 2008 Standard 64Bit  
Apache: 2.2.25 OpenSSL/0.9.8y JRUN/4.0 PHP/5.3.1
ColdFusion 9

I know the question will be asked why we are running this web stack and the answer is I do not know. The employee who set this up for the owner of the company passed away unexpectedly. We are looking at moving to IIS in the near future but if we don't get the performance issue figured out, there wont be any customers to worry about.

2

It may also depend where you got your apache binaries. The ones from apache lounge have served us great in the past. I would also suggest up or downgrading apache to another version, this specific build may have an issue.

1

It's very hard to tell without diving into a debugging session. Apache will use zlib to implement HTTP compression so you could try to disable it (there could be performance issues, specially for users on remote slow connections, depending on the kind of traffic you have).

You should consider updating to the latest version of Apache (2.2.27) and PHP (5.3.29) at least.

1
  • 1
    I believe there are some compatibility issues with ColdFusion with 2.2.27 but I'll need to double check that. Thanks for the PHP suggestion, I missed that update. – tom Aug 15 '14 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.