0

I run yum install php-devel and it returns this. Typically I'd just run it with --skip-broken, but when I do, it still doesn't do the trick.

       Available: php-common-5.3.3-22.el6.x86_64 (rhel-x86_64-server-6)
           php-common(x86-64) = 5.3.3-22.el6
       Available: php-common-5.3.3-23.el6_4.x86_64 (rhel-x86_64-server-6)
           php-common(x86-64) = 5.3.3-23.el6_4
       Available: php-common-5.3.3-26.el6.x86_64 (rhel-x86_64-server-6)
           php-common(x86-64) = 5.3.3-26.el6
       Available: php54w-common-5.4.29-2.w6.x86_64 (webtatic)
           php-common(x86-64) = 5.4.29-2.w6
       Available: php54w-common-5.4.30-1.w6.x86_64 (webtatic)
           php-common(x86-64) = 5.4.30-1.w6
       Available: php55w-common-5.5.13-2.w6.x86_64 (webtatic)
           php-common(x86-64) = 5.5.13-2.w6
       Installing: php55w-common-5.5.14-1.w6.x86_64 (webtatic)
           php-common(x86-64) = 5.5.14-1.w6
You could try using --skip-broken to work around the problem

When run with --skip-broken it returns this at the end:

Packages skipped because of dependency problems:

 autoconf-2.63-5.1.el6.noarch from rhel-x86_64-server-6
 automake-1.11.1-4.el6.noarch from rhel-x86_64-server-6
 pcre-devel-7.8-6.el6.x86_64 from rhel-x86_64-server-6
 php-5.3.3-27.el6_5.1.x86_64 from rhel-x86_64-server-6
 php-cli-5.3.3-27.el6_5.1.x86_64 from rhel-x86_64-server-6
 php-common-5.3.3-27.el6_5.1.x86_64 from rhel-x86_64-server-6
 php-mysql-5.3.3-27.el6_5.1.x86_64 from rhel-x86_64-server-6
 php-pdo-5.3.3-27.el6_5.1.x86_64 from rhel-x86_64-server-6
 php-soap-5.3.3-27.el6_5.1.x86_64 from rhel-x86_64-server-6
 php55w-cli-5.5.14-1.w6.x86_64 from webtatic
 php55w-common-5.5.14-1.w6.x86_64 from webtatic
 php55w-devel-5.5.14-1.w6.x86_64 from webtatic

This problem has arisen with a few other similar commands when installing something related to php, except I've just done without them.

I need to install this for something I'm trying to do. I do remember upgrading to PHP 5.4 and our entire infrastructure coming down due to it requiring PHP 5.3, so I downgraded as quick as possible to get everything back running and that may contribute to the issue.

If you have any idea why this is happening and how I could get the package on the system while remaining on PHP 5.3, please let me know.

Thanks.

3

Easiest thing to do at this point - get rid of the webtatic packages.

yum --disablerepo=webtatic distro-sync

Should get you on the right track for starters.

EDIT: how to disable webtatic permanently:

sed -i '/\[webtatic\]/,/^$/ s/\(enabled=\)1/\10/p' $(grep -rlF [webtatic] /etc/yum.repos.d/*.repo)

And then do

yum distro-sync

and go over the results of package-cleanup --orphans (or yum list extras) to determine any other packages that might need removal.

| improve this answer | |
  • Will do this tonight. What do I do after that? Will I still be on 5.3.3 or need to reinstall? – user3791722 Aug 15 '14 at 18:48
  • Don't just disable it, remove it entirely. Then run yum distro-sync and package-cleanup --orphans to help identify leftover packages from that repo. – Michael Hampton Aug 15 '14 at 18:50
  • php-common on rhel6 is 5.3.3 so it should remain (or possibly reinstall from the rhel6 repo). Don't use -y, and go over what yum will do before you accept anything. possibly paste here the result before you commit (press y) so we can advise further. And yes - remove webtatic from your repo file so you don't have to disable it on every subsequent command. – Dani_l Aug 15 '14 at 18:54
  • Then do I just reinstall PHP? – user3791722 Aug 15 '14 at 19:57
  • I created a droplet on digitalocean, installed the webtatic repo along with php and a ton of packages, ran the command above and in the comments, removed php, and then reinstalled and it worked great. I'll comment back results once I've done this on the real server. – user3791722 Aug 15 '14 at 20:46
1

I too had the same issue and resolve as below:

  1. First, make sure which version of PHP you have, PHP 5.3, 5.4 or 5.5
  2. Next, when you issue the command 'yum install php-devel'. Closely observe and see as which version of devel it is trying to install
  3. Next, try to search the available repos as 'yum search php53' or yum search php54 etc, based on your PHP version
  4. You should be shown the list of Packages that are available.
  5. Now, issue the command specifying the exact version that you are willing to install. Ex: yum install php53_devel.x86_64 or yum install php54w.x86_64 etc

The following SO question helped me: https://stackoverflow.com/questions/12325109/cant-install-php-devel-on-centos

| improve this answer | |
0

Typically I'd just run it with --skip-broken

So your system is now probably in an utterly messed up state. This extra 'webtatic' repo you use is likely related to that. I would at this point wipe the box and start from scratch.

| improve this answer | |
  • That's definitely not an option. I've only used that repo for PHP stuff. Is there anyway to remove php along with the packages from that repo, uninstall it, and then reinstall it properly? – user3791722 Aug 15 '14 at 18:13
  • Yes, rpm -qa | grep w6 should be a good indication of which packages come from that repo. Also get rid of the .repo file to avoid further madness from it. – Dennis Kaarsemaker Aug 15 '14 at 18:16
  • rpm -qa | grep w6 returned nothing. – user3791722 Aug 15 '14 at 18:22
  • rpm -qa only returns name, not version, so w6 wouldn't show. yum list installed | grep w6 OTOH... – Dani_l Aug 15 '14 at 18:41
  • Still returned nothing. – user3791722 Aug 15 '14 at 18:45
0

This worked for me sudo yum --enablerepo=remi,remi-php56 install php-devel

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.