1

I have an 8 disk RAID-5 array in degraded state. One drive failed some time ago, I replaced it, and it rebuilt and all was fine (state of the logical drive became optimal). Now another disk has failed (different one) only this time replacing it doesn't allow the rebuild. The controller seems to be stuck thinking the array member is missing. Here are the various things I tried:

  1. Putting in a new disk, initializing it, waiting - no luck.
  2. Marking the new disk as a specific hotspare for the logical drive - no luck.
  3. Buying a larger disk than any other array member to guarantee it isn't some sector/block count shortage issue - no luck.
  4. Putting back the older disk (the older disk still works sometimes) - logical drive remains degraded and the drive is marked inconsistent. Can't seem to do anything in this state either.
  5. With the disk in #4 plugged in set drive state to failed. It fails but doesn't remove itself from the raid array. The new disk cannot become a member of the array, it stays stuck in the ready state.

The controller itself has 8 ports so there's no free port to put a new drive in a different target and channel. Any thoughts on how I can trigger a rebuild?

  • on this page it says there are 3 different mgmt tools available; Storage Manager, CLI, and Bios Utility. Have you tried booting into the bios utility and managing the array that way? adaptec.com/fr-fr/products/controllers/hardware/sata/value/… – user16081-JoeT Aug 16 '14 at 5:49
  • I tried the CLI and the Bios Utility. The current Storage Manager gui cannot detect the card, probably too old. – Brian Aug 16 '14 at 15:11
  • Do you have a backup of your data? Have you tried Adaptec support? – user16081-JoeT Aug 16 '14 at 15:16
  • I backed up the most important data and I keep the system off whenever possible so it doesn't lose another disk while degraded. I could try Adaptec support on Monday I suppose, but the card was purchased in 2007 and is way past the 3 year warranty, but wouldn't hurt to try, thanks. – Brian Aug 16 '14 at 15:26
  • can you afford an upgrade? There's a lot of new stuff out there, i got a couple QNAPs last year, an 8-drive for work and a 4-drive for home. If not then hopefully Adaptec support can help you out; speaking of which did you try updating to the controller's latest firmware? – user16081-JoeT Aug 16 '14 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.