0
[root@ltfs1968 yum.repos.d]# yum install php-mbstring
Loaded plugins: dellsysid, downloadonly, replace, rhnplugin
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
No package php-mbstring available.
Error: Nothing to do

Just finished removing the webtatic repository and installed php and mysql. I need to now install the mbstring package and it returns this.

I've done some searching and it seems RHEL's repo does not have it. How can I add this without upgrading or downgrading from PHP 5.3.3, and without switching repos permanently or ruining my setup?

Thanks

1

It's in the "RHEL Server Optional repository".
You need to subscribe your machine to that repository via RHN.

  • How can I do this? – Noah Matisoff Aug 16 '14 at 9:12
  • Probably access.redhat.com/solutions/70019 but I don't have access to a RedHat subscription anymore to confirm. – faker Aug 16 '14 at 9:21
  • I've removed all extra repos and disabled them, and removed PHP. How can I get PHP 5.3.* on my system to work with php-mbstring and php-devel? – Noah Matisoff Aug 16 '14 at 9:28
  • Well, you need the Base repo (or whatever it is called in RHEL now) and the one I mentioned. Then just run yum install php-mbstring php-devel. – faker Aug 16 '14 at 9:51
  • @NoahMatisoff You need to add the repo, not remove it! – Michael Hampton Aug 16 '14 at 12:02

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.