There was once a computer that sent print jobs to an intermec label printer. For some reason after only a few labels the printer would stop printing. So Intermec was contacted and they changed some print configuration setting and everything was fine. Then one fine day the computer got old and was replaced by a new computer. . . wecome back old problem.

Now after just 26 labels it stops. I suspect it's running out of memory and simply dropping the rest of the print job. I've tried changing the print spool option to print directly to the printer, but that didn't resolve anything. Any ideas?

The printer is model 3400D.

  • What's the OS? What interface to the printer? More details, please. – Dennis Williamson Sep 3 '09 at 21:57
  • Windows XP Pro. Standard windows printing using the intermec print driver. BTW--I also have a PM4i printer at the other and of the plant and it does not have ths problem. – jeffspost Sep 3 '09 at 22:04
  • (The PM4i is a newer model printer--similar to the 3400, more memory, faster, etc) – jeffspost Sep 3 '09 at 22:05
  • Serial? Parallel? USB? Other? Hmmm... "more memory, faster". Have you tried swapping the PM4i in place of the 3400? – Dennis Williamson Sep 3 '09 at 22:49
  • It's on a serial connection. – jeffspost Sep 4 '09 at 16:04

If it's parallel, I'd check to see how the port is set in the PC's BIOS. Trying ECP, EPP, bidirectional or some other setting to see which works.

Ugh, since it's serial - There's your problem!

I'm assuming it's RS-232 and not RS-422 or RS-485. If the labels that it is printing are correct (no dropped or odd characters or missing parts of bar graphs), I'm betting that the problem is the protocol setting).

First, look at the dip switches on the printer and consult the manual for their meaning. Record the settings for baud rate, parity, data bits and protocol. I think you can ignore the setting for XON/XOFF Status Response (the last switch).

Second, go into the software you use to print the labels and make sure that the settings there match those that you recorded from the printer.

If your software does not control those settings, then in Windows, in the start menu, select Printers and Faxes. Right click on the correct printer in the resulting window and select Properties. Click on the Ports tab (COM1 or COM2 should already be highlighted and have a check mark), then the Configure Port button. There you will see the settings to check. Change them to match the ones you recorded from the printer.

Most likely, it will be that XON/XOFF is set (protocol dip switch is OFF) at the printer, but set to None at the computer. If that's the case, set Handshaking to Xon/Xoff at the computer. If the protocol dip switch is set to ON (Intermec protocol), then set Handshaking to Hardware at the computer.

  • It's running off a serial connection. – jeffspost Sep 4 '09 at 13:05
  • We ended up contacting Intermec support which was very responsive actually and walked through changing some settings similarly to the ones noted above. Unfortunately, since I wasn't actually invovled in that call I can't say what exactly was done. – jeffspost Sep 17 '09 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.