1

I'm completely new to VPS and am trying to install php54 on a centos6.5 server.

I've updgraded the php version to 5.4 which appears to work. Currently using php5.4.31

However I now need to install mcrypt. I've tried:

yum install php-mcrypt

I have set up remi and epel repositories and this goes so far to install but comes up with a dependency error:

Loaded plugins: fastestmirror, security
No such command: snstall. Please use /usr/bin/yum --help
[root@XXXX~]# yum install php-mcrypt*
Loaded plugins: fastestmirror, security
Determining fastest mirrors
epel/metalink                                            |  26 kB     00:00
 * base: centos.serverspace.co.uk
 * epel: mirror.bytemark.co.uk
 * extras: mirror.bytemark.co.uk
 * rpmforge: www.mirrorservice.org
 * updates: centos.hyve.com
base                                                     | 3.7 kB     00:00
base/primary_db                                          | 4.4 MB     00:01
epel                                                     | 4.4 kB     00:00
epel/primary_db                                          | 6.3 MB     00:00
extras                                                   | 3.4 kB     00:00
extras/primary_db                                        |  19 kB     00:00
rpmforge                                                 | 1.9 kB     00:00
rpmforge/primary_db                                      | 2.7 MB     00:04
updates                                                  | 3.4 kB     00:00
updates/primary_db                                       | 4.7 MB     00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.x86_64 0:5.3.3-3.el6 will be installed
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-mcrypt-5.3.3-  3.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: php-mcrypt-5.3.3-3.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel)
       Requires: php(zend-abi) = 20090626
       Installed: php-common-5.4.31-1.el6.remi.x86_64 (@remi)
           php(zend-abi) = 20100525-x86-64
       Available: php-common-5.3.3-26.el6.x86_64 (base)
           php(zend-abi) = 20090626
       Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
           php(zend-abi) = 20090626
       Available: php-common-5.3.3-27.el6_5.1.x86_64 (updates)
           php(zend-abi) = 20090626
Error: Package: php-mcrypt-5.3.3-3.el6.x86_64 (epel)
       Requires: php(api) = 20090626
       Installed: php-common-5.4.31-1.el6.remi.x86_64 (@remi)
           php(api) = 20100412-x86-64
       Available: php-common-5.3.3-26.el6.x86_64 (base)
           php(api) = 20090626
       Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
           php(api) = 20090626
       Available: php-common-5.3.3-27.el6_5.1.x86_64 (updates)
           php(api) = 20090626
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I cant seem to install mcrypt for version 5.4.

Any help appreciated

Thank you

1

The remi repository, from which you installed PHP, is disabled. Enable it and try again.

| improve this answer | |
  • Thank you. I didnt realise it had been disabled - I assumed once installed it would be enabled - still learning. mcrypt is now installed. Thanks – Ray Aug 17 '14 at 16:14
  • 1
    @Ray Remi ships the repo disabled by default, which is slightly annoying and leads to confusing issues like this. – Michael Hampton Aug 17 '14 at 16:32
  • The repository is not enabled by default because it overrides some base packages, and admin need to choose between remi, remi-php55, remi-php56, remi-php70 or remi-php71. See: rpms.remirepo.net/wizard – Remi Collet Oct 30 '16 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.