2

I'm trying to setup an apache http server with mod_wsgi on a windows machine, but when I start the service, it fails to launch.

In the Windows Event Log I get the following message:

The Apache2 service terminated with the following service-specific error: 
Incorrect function.

In running a Windows 8 - 64 bits machine, with

  • Apache 2.0.64 32 bits
  • Python 2.7.8 32 bits
  • mod_wsgi 3.5 32 bits

I looked around the web, but all the problem but everywhere says that it's a problem with the architecture of the software, but I already installed them all with the 32 bits version.

2
  • Why are you using such an ancient Apache version? It is unlikely there are downloadable binaries for mod_wsgi for Apache 2.0 around, so not sure where you sourced it from. Use binaries from lfd.uci.edu/~gohlke/pythonlibs and the Apache version referenced from there. Use 64 bits for everything is preferred, so uninstall and start over. – Graham Dumpleton Aug 19 '14 at 22:49
  • I used 2.0 because someone had managed to install the environment with that version. Switched all to the most recent 64bits versions and it worked. – TiagoOliveira Aug 20 '14 at 9:03
1

Managed to solve the problem by installing all with 64 bits version.

0

I am running wampserver in a 64 bit version (wampserver64), and apache 2.4.9 in a 64 bit version as well (wampapache64), and I downloaded mod_wsgi-3.5.ap24.win-amd64-py2.7 from here (I had to use Firefox to download as Chrome refused for some odd reason).

Even though I did all this I still got an "incorrect function" when starting Apache.

The solution is to install Python in a 64 bit version (my python version was 32 bit) and then start the service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.