13

I get a warning event with ID 20499 for TerminalServices-RemoteConnectionManager.The error is:

Remote Desktop Services has taken too long to load the user configuration from server \server.domain.home for user administrator.

Yet, I don't see any issues (I'm guessing because that user is on the machine local). Why am I getting this warning?

I'm on Windows Server 2012 R2 connecting from a Windows 8.1.

  • 2
    Are you asking a question? I don't see a question, I see a statement. – joeqwerty Aug 19 '14 at 23:22
  • What would trigger the warning? – Marc05 Aug 20 '14 at 21:25
  • Can you post the output of Get-NetOffloadGlobalSetting? – Giovanni Tirloni Sep 6 '14 at 22:30
  • In order of "ReceiveSideScaling; ReceiveSegmentedCoalescing; Chimney; TaskOffload; NetworkDirect; networkDirectAcrossIPSubnets; PacketCoalescingFilter": Client Enabled; Disabled; Disabled; Enabled; Disabled; Blocked; Enabled. Server Enabled; Enabled; Disabled; Enabled; Enabled; Blocked; Disabled. – Marc05 Sep 7 '14 at 23:30
  • There is a thread on the MS boards about that. It has been going on since 2013. And no end in sight as of now (Feb 2016). Seems like a benign but annoying event. MS-Forums: Remote Desktop Services has taken too long to load the user configuration from server Event ID 20499 – StackzOfZtuff Feb 25 '16 at 11:12
4

This will solve your problem:

In Registry Editor, locate and then click one of the following registry subkeys:

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows NT\Terminal Services

Add DWORD fQueryUserConfigFromLocalMachine with value 1

restart

Reference https://support.microsoft.com/nl-nl/help/4021856/sbsl-issue-when-you-create-an-rdp-connection-to-windows-server

| improve this answer | |
3

Apparently this can be triggered by using mRemote / Remote Desktop Connection Manager (RCDMan 2.2) or similar software.

The fix is to set TaskOffload = Disabled using Set-NetOffloadGlobalSetting

Source: http://www.itnotes.eu/?p=1193

| improve this answer | |
  • Unfortunately, this didn't work. I both set TaskOffload to disabled in powershell, and disabled each TCP/IP offload feature on the adapter itself. I then restarted the server, but still get the same warning. – Marc05 Apr 25 '15 at 1:54
  • 3
    This is always the answer I read everywhere. But what does this "TaskOffload" do? And why does it trigger the warning when enabled? Could you please elaborate? – Tom Aug 30 '16 at 7:33
  • This didn't work. – M. S. Oct 6 '16 at 17:59
  • The new url for Set-NetOffloadGlobalSetting is here: docs.microsoft.com/en-us/powershell/module/nettcpip/… – sippybear Feb 20 '18 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.