11

My do-release-upgrade fails. I get the following error message:

Checking for a new Ubuntu release
Your Ubuntu release is not supported anymore.
For upgrade information, please visit:
http://www.ubuntu.com/releaseendoflife

Err Upgrade tool signature
  404  Not Found [IP: 2001:67c:1360:8c01::19 80]
Err Upgrade tool
  404  Not Found [IP: 2001:67c:1360:8c01::19 80]
Fetched 0 B in 0s (0 B/s)
WARNING:root:file 'raring.tar.gz.gpg' missing
Failed to fetch
Fetching the upgrade failed. There may be a network problem.

So it says my version is not supported anymore. I have Ubuntu Quantal (12.10). What should I do now?

6
  • It might not hurt to mention which version you currently have. Also, do you have any network problems?
    – jscott
    Aug 20 '14 at 12:41
  • No, no networking problems. I've got Ubuntu quantal (12.10). Aug 20 '14 at 12:56
  • I have a system, which was installed with 13.04 and upgraded from that to 13.10 and later to 14.04. But I upgraded to 13.10 long before 14.04 was released, so things may have changed. It might be that upgrading directly from 13.04 to 14.04 is not supported, and it might be that upgrading to 13.10 is no longer supported. When upgrading from 12.04 to 14.04 I found that the -p parameter was required in order to perform the upgrade, though the error message I got was different.
    – kasperd
    Aug 20 '14 at 13:00
  • @Kevin raring is 13.04. Are you trying to upgrade from 12.10 to 13.04? The supported releases are 12.04 and 14.04. I guess you want to upgrade to 14.04. If you would be going through 13.04 and 13.10 to get there it is going to take a while, it might be less work to do a fresh install of 14.04 instead of running through three upgrades. So the real question might actually be how to upgrade directly to 14.04 LTS. Which release does it chose, if you run do-release-upgrade -p?
    – kasperd
    Aug 20 '14 at 13:06
  • Hi, thanks for your answer! If I add the -p parameter, then I get exactly the same message: Aug 20 '14 at 13:20
15

I had this exact same issue and this answer solved the issue for me.

In summary:

The repositories for older releases that are not supported get moved to an archive server. There are repositories available at http://old-releases.ubuntu.com

So you have to rewrite your /etc/apt/sources.list file in order to use this server. Use the following sed command to do this:

sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

Also comment out any entries in sources.list that point to mx.* servers

Now you are ready to do your update:

sudo apt-get update
sudo apt-get install update-manager-core
sudo do-release-upgrade
1
  • nope: E: GPG error: http://us.old-releases.ubuntu.com trusty InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)
    – noahz
    Jan 17 '16 at 19:13
9

You have to change all apt-sources from archive.ubuntu.com or security.ubuntu.com to "old-releases.ubuntu.com".

If you use the standard hostnames, as described above, you an replace this using:

sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

If you are using subdomains of mirrors in your country (e.g. "us.archive.ubuntu.com") use this command:

sudo sed -i -e 's/us.archive.ubuntu.com\|us.security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

old-releases.ubuntu.com doesn't support country-code-subdomains.

4

Change all of your apt-sources to "old-releases.ubuntu.com". This sed command works with any/all ubuntu.com URLs and saves a backup copy in case you need to revert:

sudo sed -i.save -e 's/\/\/.*ubuntu.com/\/\/old-releases.ubuntu.com/g' /etc/apt/sources.list

Upgrade all packages in your current (old and outdated) release and make sure you have the update manager installed:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install update-manager-core

Reboot:

sudo reboot

Upgrade to the latest release:

sudo do-release-upgrade
6
  • Thanks, that allowed me to upgrade from 19.04 to 20.04 (via 19.10).
    – Cleb
    May 23 '20 at 20:17
  • My old machine has 17.04 and this didn't do it.
    – Patrick
    Jul 16 '20 at 23:39
  • Trying again after doing s/zesty/artful/g and seems to be making progress.
    – Patrick
    Jul 17 '20 at 0:05
  • @Patrick what? how did you get it to work? zesty artful what?
    – CQM
    Jan 9 at 5:45
  • 1
    @CQM I manually bumped the distribution it was looking for to the one dist-upgrade was supposed to use.
    – Patrick
    Jan 12 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.