14

My do-release-upgrade fails. I get the following error message:

Checking for a new Ubuntu release
Your Ubuntu release is not supported anymore.
For upgrade information, please visit:
http://www.ubuntu.com/releaseendoflife

Err Upgrade tool signature
  404  Not Found [IP: 2001:67c:1360:8c01::19 80]
Err Upgrade tool
  404  Not Found [IP: 2001:67c:1360:8c01::19 80]
Fetched 0 B in 0s (0 B/s)
WARNING:root:file 'raring.tar.gz.gpg' missing
Failed to fetch
Fetching the upgrade failed. There may be a network problem.

So it says my version is not supported anymore. I have Ubuntu Quantal (12.10). What should I do now?

6
  • It might not hurt to mention which version you currently have. Also, do you have any network problems?
    – jscott
    Aug 20, 2014 at 12:41
  • No, no networking problems. I've got Ubuntu quantal (12.10). Aug 20, 2014 at 12:56
  • I have a system, which was installed with 13.04 and upgraded from that to 13.10 and later to 14.04. But I upgraded to 13.10 long before 14.04 was released, so things may have changed. It might be that upgrading directly from 13.04 to 14.04 is not supported, and it might be that upgrading to 13.10 is no longer supported. When upgrading from 12.04 to 14.04 I found that the -p parameter was required in order to perform the upgrade, though the error message I got was different.
    – kasperd
    Aug 20, 2014 at 13:00
  • @Kevin raring is 13.04. Are you trying to upgrade from 12.10 to 13.04? The supported releases are 12.04 and 14.04. I guess you want to upgrade to 14.04. If you would be going through 13.04 and 13.10 to get there it is going to take a while, it might be less work to do a fresh install of 14.04 instead of running through three upgrades. So the real question might actually be how to upgrade directly to 14.04 LTS. Which release does it chose, if you run do-release-upgrade -p?
    – kasperd
    Aug 20, 2014 at 13:06
  • Hi, thanks for your answer! If I add the -p parameter, then I get exactly the same message: Aug 20, 2014 at 13:20

5 Answers 5

16

I had this exact same issue and this answer solved the issue for me.

In summary:

The repositories for older releases that are not supported get moved to an archive server. There are repositories available at http://old-releases.ubuntu.com

So you have to rewrite your /etc/apt/sources.list file in order to use this server. Use the following sed command to do this:

sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

Also comment out any entries in sources.list that point to mx.* servers

Now you are ready to do your update:

sudo apt-get update
sudo apt-get install update-manager-core
sudo do-release-upgrade
3
  • nope: E: GPG error: http://us.old-releases.ubuntu.com trusty InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)
    – noahz
    Jan 17, 2016 at 19:13
  • Your sed command didn't work for me because my existing URLs started with us., I had to do sudo nano /etc/apt/sources.list and manually remove the us. part from all the URLs. After that I got some Err:5 http://old-releases.ubuntu.com/ubuntu groovy Release 404 Not Found [IP: and Updating from such a repository can't be done securely, and is therefore disabled by default errors/warnings, which was concerning. So I just gave up and spun up a new server with a newer OS from scratch and copied over my files... Dec 5, 2021 at 4:14
  • An upgrade from 'groovy' to 'impish' is not supported with this tool. === Command terminated with exit status 1 (Tue Apr 5 17:15:37 2022) === Apr 6 at 0:15
9

You have to change all apt-sources from archive.ubuntu.com or security.ubuntu.com to "old-releases.ubuntu.com".

If you use the standard hostnames, as described above, you an replace this using:

sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

If you are using subdomains of mirrors in your country (e.g. "us.archive.ubuntu.com") use this command:

sudo sed -i -e 's/us.archive.ubuntu.com\|us.security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

old-releases.ubuntu.com doesn't support country-code-subdomains.

7

Change all of your apt-sources to "old-releases.ubuntu.com". This sed command works with any/all ubuntu.com URLs and saves a backup copy in case you need to revert:

sudo sed -i.save -e 's/\/\/.*ubuntu.com/\/\/old-releases.ubuntu.com/g' /etc/apt/sources.list

Upgrade all packages in your current (old and outdated) release and make sure you have the update manager installed:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install update-manager-core

Reboot:

sudo reboot

Upgrade to the latest release:

sudo do-release-upgrade
7
  • Thanks, that allowed me to upgrade from 19.04 to 20.04 (via 19.10).
    – Cleb
    May 23, 2020 at 20:17
  • My old machine has 17.04 and this didn't do it.
    – Patrick
    Jul 16, 2020 at 23:39
  • Trying again after doing s/zesty/artful/g and seems to be making progress.
    – Patrick
    Jul 17, 2020 at 0:05
  • @Patrick what? how did you get it to work? zesty artful what?
    – CQM
    Jan 9, 2021 at 5:45
  • 1
    @CQM I manually bumped the distribution it was looking for to the one dist-upgrade was supposed to use.
    – Patrick
    Jan 12, 2021 at 20:03
0

I had similar problem. The only way of upgrading that worked in my case was:

wget http://archive.ubuntu.com/ubuntu/dists/hirsute-updates/main/dist-upgrader-all/current/hirsute.tar.gz
tar -xvf hirsute.tar.gz
sudo ./hirsute

Details here: https://blog.invid.eu/2022/02/24/upgrade-eol-ubuntu-server-from-20-10-to-21-10-an-upgrade-from-groovy-to-impish-is-not-supported-with-this-tool-ubuntu-ubuntugeek-ubuntu-linux-eol-upgrade/

I wanted to upgrade from 20.10 to 22.04, but the intermediate step was to upgrade from 20.10 to 21.04. Nevertheless, the procedure should work for any past and future Ubuntu distribution.


Note! Before running the UpgradeTool I added the old-releases. to the domains/entries in the /etc/apt/sources.list. Operation similar to the one described in randomcontrol's answer:

sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

so that the:

sudo apt-get update

would work.


Additional information on that approach in the official documentation: https://help.ubuntu.com/community/EOLUpgrades

-1

Check this out https://butlerraines.com/code-stuff/upgrading-end-life-eol-ubuntu-version-ubuntu-1904

This is for Ubuntu 19.04 but should work for any distro.

3
  • 1
    Please don't post link only questions, they become useless when the link dies. Instead, post the essentials and link to the source for reference. Mar 29 at 4:48
  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Davidw
    Apr 1 at 3:28
  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 2 at 12:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.