4

For botting purposes, I have to keep my Win Server 2012 R2 running without logging-off after I disconnect from Remote Session.

Found information about it here: http://technet.microsoft.com/en-us/library/cc754272.aspx but I just its for Win Server 2008 and doesn't seem to work on 2012 version.

Could you guys help me setting infinite timout?

EDIT: Tried this answer Changing the login timeout for Windows Remote Desktop Services but without results..

MORE DETAIL ABOUT WHAT I NEED: I connect to Amazon ECL Istance with "Remote Desktop Conection". I need to put remote server to keep running as if an user was normally remotely logged in, and prevent it from going to that log-out stand-by screen, usually blue coloured @ winserver2012, because i'm using macros that take screenshots of screen and find bitmap positions, do clicks, move mouse and stuff..

  • Are you using the RDP to an admin session, or to a full Remote Desktop Services Deployment. If you are just using a remote admin connection, the already is set to not timeout. – Zoredache Aug 21 '14 at 0:04
  • I connect to Amazon ECL Istance with "Remote Desktop Conection". I need to put remote server to keep running as if I was normally remotely logged in, and prevent it from going to that log-out stand-by screen, usually blue coloured @ winserver2012, because i'm using macros that take screenshots of screen and find bitmap positions, do clicks, move mouse and stuff... – Sarchophagi Aug 21 '14 at 2:54
  • Sounds to me like you really need to be looking at the screen saver settings. – Zoredache Aug 21 '14 at 5:23
4

If you are in an AD environment create a GPO for your administrator account or group. The policy you're looking for is User Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits\Set time limit for active but idle Remote Desktop Services sessions (set to disabled).

If you are not in an AD environment you want to use Local Security Policy. The policy you're looking for here is Local Policies\Security Options\Microsoft network server: Amount of idle time required before suspending session (set to 99999, or 208 days, which is the maximum).

  • 1
    In "Local Policies\Security Options\Microsoft network server: Amount of idle time required before suspending session", will not 0 make it never disconnect? – uranibaba Dec 21 '16 at 9:03
4

You need to configure the Computer Configuration's Remote Desktop Session Host policies:

  • launch the Global Policy Editor with typing gpedit.msc from the command-line and hit Enter.
  • In the left panel, navigate to Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Session Time Limits.
  • In the right panel, double-click the Set time limit for active but idle Remote Desktop Services sessions policy: in the modal window that will appear, activate it by switching the radio button from Not configured to Enabled, then set the desired amount of time in the drop-down list right below.

enter image description here

That's it: from now on, your remote users will also receive a pop-up warning 2 minutes before the session time expiration, so they'll have the chance to keep their session on (if they're still there): if they do nothing, they will be disconnected.

For additional info and other related policy settings, read here.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.