0

I have a website on a bucket in Amazon S3, and recently started to get emails from Google "Googlebot can't access your site". When I go to Webmaster Tools and I try to fetch in fact it doesn't work. Also people in locations different from mine sometimes reported they could not access the website.

Now for curiosity I tried from my terminal:

$ host xxx
xxx is an alias for xxx.s3-website-us-west-1.amazonaws.com.
xxx.s3-website-us-west-1.amazonaws.com is an alias for s3-website-us-west-1.amazonaws.com.
s3-website-us-west-1.amazonaws.com has address yyy.yyy.yyy.yyy

And when I try with dig:

$ dig xxx

; <<>> DiG 9.8.3-P1 <<>> xxx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17860
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;xxx.       IN  A

;; ANSWER SECTION:
xxx.    300 IN  CNAME   xxx.s3-website-us-west-1.amazonaws.com.
xxx.s3-website-us-west-1.amazonaws.com. 60 IN CNAME s3-website-us-west-1.amazonaws.com.
s3-website-us-west-1.amazonaws.com. 60 IN A yyy

;; Query time: 1514 msec
;; SERVER: 75.75.75.75#53(75.75.75.75)
;; WHEN: Fri Aug 22 12:32:13 2014
;; MSG SIZE  rcvd: 127

It seems OK to me. Why would Google tell me there is a DNS error?

UPDATE:

Google also cannot fetch robots.txt, but I can fetch it from my browser.

UPDATE 2:

I have a forwarding on the root to the www.* hostname:

$ dig thenifty.me

; <<>> DiG 9.8.3-P1 <<>> thenifty.me
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49286
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;thenifty.me.           IN  A

;; AUTHORITY SECTION:
thenifty.me.        300 IN  SOA ns1hwy.name.com. support.name.com. 1 10800 3600 604800 300

;; Query time: 148 msec
;; SERVER: 75.75.75.75#53(75.75.75.75)
;; WHEN: Fri Aug 22 13:32:56 2014
;; MSG SIZE  rcvd: 88
2
  • Why don't you give us the actual domain name so we can take a look? I'm also unclear as to how you got from "Googlebot can't access your site" to "DNS error" - did Google Webmaster Tools tell you it was a DNS issue? – ceejayoz Aug 22 '14 at 19:46
  • Yes, the message in the dashboard of Webmaster Tools is "Google couldn't access your site because of a DNS error." The site in question is thenifty.me – aledalgrande Aug 22 '14 at 19:49
1

dig thenifty.me:

No answer section.

dig www.thenifty.me:

;; ANSWER SECTION:
www.thenifty.me.    299 IN  CNAME   www.thenifty.me.s3-website-us-west-1.amazonaws.com.
www.thenifty.me.s3-website-us-west-1.amazonaws.com. 59 IN CNAME s3-website-us-west-1.amazonaws.com.
s3-website-us-west-1.amazonaws.com. 59 IN A 176.32.116.11

It is likely that Googlebot checked both www and non-www and reported an error due to your lacking records for the non-www variant. This is also likely to be why some users can't get to the site - they leave off the www when they type it in.

8
  • I have a 301 redirect to www.* for the non-www variant, is there a way I can fix this? – aledalgrande Aug 22 '14 at 19:52
  • 1
    How can you have a 301 redirect in place without DNS records? – ceejayoz Aug 22 '14 at 20:09
  • I configured it from the interface of name.com, maybe it's more correct to call it Forwarding? – aledalgrande Aug 22 '14 at 20:15
  • 1
    If you set up forwarding for the non-www in Name.com, you need to contact their support, because it didn't work. There'd be a DNS record of some sort if it worked correctly. – ceejayoz Aug 22 '14 at 20:28
  • 1
    That response indicates no records. You'll see the same response for dig pqoiweurpower.thenifty.me. – ceejayoz Aug 22 '14 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.