0

i have a problem on my domain, the history starting from when i had a server with WIN 2008 r2 installed with the following roles installed on it (AD, DNS, DHCP, File). From 1 month i decided to install a new server 2008 r2 server to get (AD, DNS, DHCP) and leave the file server on the old one. i did the following exactly:

1) robocopy all my data on external HDD

2) Install a new server with 2008 r2

3) transfer all 5 roles to transfer the domain to the new server (MainDC)

4) issue (NETLOGON, SYSVOL) not transferred but i decided to reinitialize them again an now they are operating (MainDC)

5) re-create and re-configure a new GPOs and link it to my OUs

6) reinstall Old server operating system with a fresh installation of WIN 2008 R2 (FileServer)

7) join my domain with my domain credentials.

the issue when i tried to share folder on \fileserver the permissions that i had set in sharing permissions are applied on the main shared folder and subfolders. the security settings are not applied. i.e. Say i'm sharing \fileserver\MainFolder with sharing permission for Authenticated Users that can read, so every one can read this main shared folder, if i set security permission for \fileserver\MainFolder\User1 that User1 can Read\Write\Modify. User1 can not perform this processes when accessing it from Network Share, i tried alot of steps from topics online get ownership for folder, remove inheritance from parent folder, applying changes for child objects, i tried also to construct a new folder structure but also the same issue, i tried another host PC, also i get the same issue.

  • If I understood correctly, User1 can read his folder but can not write and modify? – Dusan Bajic Aug 23 '14 at 15:19
  • yup, that 's it – Muhammad Adly Aug 24 '14 at 8:05
2

Share permissions are a vestigial remnant of Windows for Workgroups and other pre-NTFS operating systems. Before NTFS, it was not possible to define different permissions for individual files and folders within a share.

Today, share permissions are largely irrelevant. In most cases, they should be set to allow Full Control for all users who need any type of access to the share. More restrictive/granular NTFS permissions can be set under the Security tab.

Because you have allowed Read access at the share level instead of Full Control, the share is currently read-only, regardless of your NTFS permissions.

1

You've granted users the Read permission on the shared folder. That means that they will only have Read access to all of the folders and files within the shared folder when accessing those folders and files over the network via the shared folder. You can do one of two things:

  1. Grant your users Full permissions on the share and set specific NTFS permissions on the folders and files within the share to control access to those folders and files. This is how most people do it.

  2. Give users a shortcut for the folders that they need access to within the share. The bypass traverse checking user right will then allow them to get to those folders directly without navigating to them via the share.

See here for a good explanation of how Share and NTFS permissions work together to grant users access to folders and files via network shares.

http://blogs.msmvps.com/acefekay/2011/02/04/share-permissions-and-ntfs-permissions-folder-access-control-amp-folder-permissions/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.