1

I have a Network drive Shared in a Workgroup with 3 clients. Two clients with Windows 7 have persistent connections to the Share. No issues with those two.

My windows 8.1 client keeps prompting for credentials at every restart / log on. I spent hours looking around for a solution:

  • I have stored cred in cred manager, and tried every possible combination (WORKGROUP\user , COMPUTERNAME\user, user, .. and so on).
  • I have changed NT and NTLM negotiation in policy manager.
  • I've compared the settings under GPO network security with a working win 7 computer, everything is pretty much the same. -I've captured Wireshark to see SMB negotiation process, honestly I see the messages flowing around, and the share sending AUTH DENIED.. which means is how the 8.1 client formats the request.... that makes the share reject it.. Now I still don't really know why.

Any ideas would be appreciated.

0

Assuming you know the credentials, write down the network path to the existing mapped drive.

Then right click on the mapped drive and select "Disconnect". Go to "My Computer" or "My PC" (where you see all of the drives listed).

Select "Map network drive"

Enter the network path to the drive you just disconnected. Select use other credentials (if necessary). When prompted for credentials, select the checkbox to "Remember my credentials".

  • Yes I have the credentials, that is no issue, the issue is to have to type them over and over. I have also tried typing them in credentials manager in every possible flavor... with no luck. Regards. – Peret del Trunfa Aug 23 '14 at 17:20
0

This workaround solved it for me.

In Windows I launched the "Credential Manager" and edited username entries like

THISPC\USERNAME 

to

OTHERPC\USERNAME 

leaving the passwords as were, or manually typing them, if the USERNAME changed.

More info at https://superuser.com/a/262598/110335

0

Do you have any other Connections to another Share with different Credentials?

If so, try to disconnect them and test your network share again by only using one network share with one user at a time.

Another suggestion: Try to connect within the IP address instead of the hostname.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.