-2

I have a virtual server under centos 5.5 (hosted by a japanese company called sakura )

Since yesterday, connection through ssh couldn't be established. I've contacted support center who told me to restart VS from the control panel. After restarting, I got the message below

Connected to domain wwwxxxxxx.sakura.ne.jp                                     
Escape character is ^]                                                          

[  OK  ]                                                                        
Setting hostname localhost.localdomain:  [  OK  ]                               

Setting up Logical Volume Management:   No volume groups found                  
[  OK  ]                                                                        

Checking filesystems                                                            
Checking all file systems.                                                      

[/sbin/fsck.ext4 (1) -- /] fsck.ext4 -a /dev/vda3                               
/ contains a file system with errors, check forced.                             

/: Inodes that were part of a corrupted orphan linked list found.               


/: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.                                 
        (i.e., without -a or -p options)                                        

@@cat: /proc/self/attr/current: Invalid argument                                
                Welcome to CentOS                                               

Starting udev: @[  OK  ]                                                        
Setting hostname localhost.localdomain:  [  OK  ]                               

Setting up Logical Volume Management:   No volume groups found                  
[  OK  ]                                                                        

Checking filesystems                                                            
Checking all file systems.                                                      

[/sbin/fsck.ext4 (1) -- /] fsck.ext4 -a /dev/vda3                               
/ contains a file system with errors, check forced.                             

/: Inodes that were part of a corrupted orphan linked list found.               


/: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.                                 
        (i.e., without -a or -p options)                                        

[FAILED]                                                                        


*** An error occurred during the file system check.                             
*** Dropping you to a shell; the system will reboot                             

*** when you leave the shell.                                                   
*** Warning -- SELinux is active                                                

*** Disabling security enforcement for system recovery.                         
*** Run 'setenforce 1' to reenable.                                             

/etc/rc.d/rc.sysinit: line 53: /selinux/enforce: Read-only file system          
Give root password for maintenance                                              

(or type Control-D to continue):                                                
bash: cannot set terminal process group (-1): Inappropriate ioctl for device    

bash: no job control in this shell                                              
bash: cannot create temp file for here-document: Read-only file system          

bash: cannot create temp file for here-document: Read-only file system          
bash: cannot create temp file for here-document: Read-only file system          

bash: cannot create temp file for here-document: Read-only file system          
bash: cannot create temp file for here-document: Read-only file system          

bash: cannot create temp file for here-document: Read-only file system          
bash: cannot create temp file for here-document: Read-only file system          

bash: cannot create temp file for here-document: Read-only file system          
bash: cannot create temp file for here-document: Read-only file system          

bash: cannot create temp file for here-document: Read-only file system          
(Repair filesystem) 1 # setenforce 1                                            

setenforce: SELinux is disabled                                                 
(Repair filesystem) 2 # echo 1  
(Repair filesystem) 4 # /etc/init.d/sshd  status

openssh-daemon is stopped
(Repair filesystem) 5 # /etc/init.d/sshd  start
Starting sshd: NET: Registered protocol family 10

lo: Disabled Privacy Extensions
touch: cannot touch `/var/lock/subsys/sshd': Read-only file system


(Repair filesystem) 6 # sudo /etc/init.d/sshd  start
sudo: sorry, you must have a tty to run sudo

(Repair filesystem) 7 #   

I have 4 site in production and I need to restart the server quickly (SSH + HTTPD ,...).

Thank you for your time.

closed as off-topic by Jenny D, Dennis Kaarsemaker, MichelZ, mdpc, Ward Aug 24 '14 at 4:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – Dennis Kaarsemaker, MichelZ, Ward
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Do you have known good backups ? You should probably read the fsck documentation too. – Iain Aug 23 '14 at 14:00
  • 1
    my last DB backup is quite old .. more than 2 weeks ... – canu johann Aug 23 '14 at 14:02
  • 5
    This question appears to be off-topic because the answer was included in the error message posted in the question – Jenny D Aug 23 '14 at 16:00
4

You are in the filesystem maintenance screen. At this point, you just need to do as the prompts instruct.

Run a manual filesystem check with:

fsck -y /

Once this is done, you can type exit and the system will reboot.

Not the answer you're looking for? Browse other questions tagged or ask your own question.