1

can someone please help me with this CentOS 5 question?

I am trying to install php-imap, i tried

yum install php-imap

but I am getting the following output:

Loaded plugins: fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * base: centos.hostingxtreme.com
 * epel: mirror.steadfast.net
 * extras: mirror.team-cymru.org
 * updates: mirror.beyondhosting.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-imap.x86_64 0:5.1.6-44.el5_10 set to be updated
--> Processing Dependency: php-common = 5.1.6-44.el5_10 for package: php-imap
--> Finished Dependency Resolution
php-imap-5.1.6-44.el5_10.x86_64 from updates has depsolving problems
  --> Missing Dependency: php-common = 5.1.6-44.el5_10 is needed by package php-imap-5.1.6-44.el5_10.x86_64 (updates)
Error: Missing Dependency: php-common = 5.1.6-44.el5_10 is needed by package php-imap-5.1.6-44.el5_10.x86_64 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

I already have php-common installed, I ran "yum install php-common" and got the following output

Loaded plugins: fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * base: centos.hostingxtreme.com
 * epel: mirror.steadfast.net
 * extras: mirror.team-cymru.org
 * updates: mirror.beyondhosting.net
Setting up Install Process
Package matching php-common-5.1.6-44.el5_10.x86_64 already installed. Checking for update.
Nothing to do

how can I fix this problem?

  • I would really prefer to get some help or explaination instead of voting down my question, thank you – TMMDev Aug 25 '14 at 9:49
  • I don't get the downvote. This is a non-obvious problem. – Michael Hampton Aug 25 '14 at 12:12
0

I suspect you have something corrupted somewhere in the RPM database or yum cache. I'd clear them all out and rebuild them.

First the RPM db:

rm -f /var/lib/rpm/__db.*
rpm --rebuilddb   # In later versions, this command changed to  rpmdb --rebuilddb

Then the yum cache:

yum clean all

Then bring everything back in sync with the latest on the remote repositories:

yum distro-sync

Finally, try installing the package again.

  • I am not very good at linux, the server is live and i dont want to miss things up, if i do as you say above, will this effect other programs installed? thank you. – TMMDev Aug 25 '14 at 14:34
  • @TMMDev then you probably shouldn't have root access. – Tom O'Connor Aug 25 '14 at 14:37
  • @TomO'Connor thank you for your notice, i have configured the server from zero and installed all programs, i am just asking the proffesionals if this will effect the server or not. – TMMDev Aug 25 '14 at 14:42
  • @TMMDev If you follow the directions exactly as given then you will not cause any damage. – Michael Hampton Aug 25 '14 at 14:43
  • @MichaelHampton i followed your instructions, however, yum distro-sync outputs yum help, i tried to install the imap package "yum install php-imap" i got the same problem in the main question (it is not working), what should i do now? – TMMDev Aug 25 '14 at 14:51
0

In that case, I would prefer to remove php-common completely and then try to install php-imap.

yum remove php-common*
yum install php-imap

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.