I see a lot of this kind of problem, but with the "Address already in use" error and not the "Permission Denied" error I am getting.

I installed OpenDKIM via this blog:


And everything went swimmingly until I restarted Postfix and my log immediately blasts with:

OpenDKIM Filter: Unable to bind to port inet:8891@localhost: Permission denied
OpenDKIM Filter: Unable to create listening socket on conn inet:8891@localhost
smfi_opensocket() failed

I have verified that nothing else is listening on that port and I have gone back through the blog post and can confirm that everything else is correct.

[root@server opendkim]# ps aux | grep opendkim
root     18173  0.0  0.0 103252   864 pts/0    S+   18:39   0:00 grep opendkim
[root@server opendkim]#

[root@server opendkim]# netstat -nlp | grep 8891
[root@server opendkim]#

I suspect this is something to do with selinux stopping this from creating another listener, however I do not know how to change that. Or, perhaps I'm way off base.


Try running the following command

semanage port -a -t milter_port_t -p tcp 8891
  • 1
    Would you mind to give a brief explanation and expected output before I run it? I'll do some research as well. – Luke Pittman Aug 26 '14 at 2:23
  • Did some research and ran the command as suggested. Solved that problem! Thanks. I will mark the question as answered. Unfortunately I have other issues now. – Luke Pittman Aug 26 '14 at 2:41
  • opendkim can be tricky beast – Mike Aug 26 '14 at 4:41
  • Yeah I'm starting to see that. It is running properly now, however it does not appear to be signing outgoing email. Sigh. – Luke Pittman Aug 26 '14 at 4:42
  • If that is the case then the domain is set wrong or mall isn't passing through it – Mike Aug 26 '14 at 16:17

I had the same problem too - turned out to be a typo (on Ubuntu 16 - did not work after upgrade from 14).

I missed the "inet" part of the adress (also given in original question, I just hat "8891@localhost" and not "inet:8891@localohst") from the /etc/default/opendkim. Also, I had the very same setting in the /etc/opendkim.conf before, which seems to be ignored in the new version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.