2

I have a Server2003 server which started to have the error in the subject:

System error 52 has occured "You were not connected because a duplicate name exists on the network."

I get this error when I'm trying to access the server named "FileX" (server 2012) by it's A name record "store" such as "net view //store"

There is an A record on the DNS server "store" which points to the IP address of the FileX server (10.0.150.100).

This happens to be the only server 2003 server, so I can't replicate if this happens in all the servers or not.

"nbtstat -a store" returns "Host not fount" error.

net view //FileX does lists the files, no problems there.

I have tried the following:

Add NetBios name for the server: http://www.techrepublic.com/blog/the-enterprise-cloud/adding-multiple-netbios-names-for-windows-servers/ -> I made this on the FileX server, but did not reboot.

The suggestion provided by MS: http://support.microsoft.com/kb/914056 -> Tried it on the Server2003 machine, did not work.

I have tried editing the hosts file, disabling NetBIOS but haven't found a cure yet.

I'm not very familiar with netbios (too old for me) so I'm expecting some help.

1

Try creating a CNAME record to replace the A record. It's been a while since I last encountered this error but I believe this worked in conjunction with the kb914056 fix.

First in DNS create a CNAME record instead of a normal Host(A) record.

Launch your registry editor Create a new DWORD key in the registry

On the server open regedit and navigate yo:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

Create a new DWORD with the following details:

 Value name: DisableStrictNameChecking
 Data type: REG_DWORD
 Radix: Decimal
 Value: 1
1
  • I did what you've explained but it did not work. Thanks for the response. – user2629636 Aug 27 '14 at 0:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.