0

We added a datacenter to our cluster and it is shown as "Unknown DataCenter". The dashboard reports all the agents as connected, and neither the agents logs nor opscenter logs show any error.

The steps we followed were the following:

  • We added a datacenter using the official procedure (with vnodes enabled)
  • It appeared normally in OpsCenter
  • We realized we didn't want vnodes so we decomissioned all the nodes in the new datacenter
  • We disabled vnodes in the config and restarted the new servers (after cleaning data/commitlog dirs)
  • They are properly joined to the cluster according to nodetool status
  • OpsCenter shows them as "Unknown"

We tried uninstalling/reinstalling both the agents and OpsCenter with no success. We also tried removing everything in the OpsCenter keyspace and removing the cluster from the UI.

  • 1
    What version of OpsCenter are you using? – arre Aug 28 '14 at 19:59
  • We are using OpsCenter 5.0 on Cassandra 2.0.6 – alprema Aug 28 '14 at 20:49
0

The datacenter is now properly displayed. What seems to have been a problem is the lack of Keyspaces replicated to the new datacenter.

During our first attempt to join the datacenter to the cluster, the OpsCenter Keyspace was still using SimpleStrategy and was replicated to the new nodes, but we changed it to NetworkTopologyStrategy before the second attempt.

So when we altered our business Keyspaces to be replicated on the new datacenter, the new DC was displayed in OpsCenter right away.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.