0

I'm experiencing different behavior with an openssl from a linux host and a windows host.

I have a pfx that I generated via a windows ca. I use openssl to dissect that pfx to create 3 pem files (ca cert, identity cert, and key).

I ran the following command from both a windows host and a linux host with openssl using the same pfx file:

openssl pkcs12 -in cert1.pfx -nocerts -out private.key -nodes -password pass:password

The contents of private.key from the windows host is:

-----BEGIN EC PRIVATE KEY-----

If I run the same command from a linux host the contents of the private.key file are:

-----BEGIN PRIVATE KEY-----

As a side note I'm playing around with certs and an Aruba device. For some reason the Aruba device does not like the first private key (not sure why, it probably has something to do with an EC encrypted private key, it will take the one I generate from the linux host just fine). I just can't seem to figure out how to generate a non EC private key from my windows host. It's kind of a PIA to generate a pkcs12 from my windows ca, copy it over to a linux host to dissect the private key out, and then upload it to my aruba device. Any suggestions or help on how to generate a non ec private key from openssl via windows?

0

I installed a newer version of OpenSSL on Windows and it appears to be generating the private keys properly now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.