1

I got error update coreutils.

Here is console log

root@server70 [~]# yum update coreutils
Loaded plugins: fastestmirror, refresh-packagekit, rhnplugin
Loading mirror speeds from cached hostfile                  
 * cloudlinux-x86_64-server-6: xmlrpc.cln.cloudlinux.com    
Setting up Update Process                                   
Resolving Dependencies                                      
--> Running transaction check                               
---> Package coreutils.x86_64 0:8.4-31.el6 will be updated  
---> Package coreutils.x86_64 0:8.4-31.el6_5.2 will be an update
--> Finished Dependency Resolution                              

Dependencies Resolved

=================================================================================================
 Package          Arch          Version                  Repository                         Size 
=================================================================================================
Updating:                                                                                        
 coreutils        x86_64        8.4-31.el6_5.2           cloudlinux-x86_64-server-6        3.0 M 

Transaction Summary
=================================================================================================
Upgrade       1 Package(s)

Total download size: 3.0 M
Is this ok [y/N]: y
Downloading Packages:
coreutils-8.4-31.el6_5.2.x86_64.rpm                                       | 3.0 MB     00:03
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : coreutils-8.4-31.el6_5.2.x86_64                                               1/2
Error unpacking rpm package coreutils-8.4-31.el6_5.2.x86_64
error: unpacking of archive failed on file /bin/cat: cpio: rename
Unable to send message to PackageKit
coreutils-8.4-31.el6.x86_64 was supposed to be removed but is not!
  Verifying  : coreutils-8.4-31.el6.x86_64                                                   1/2
  Verifying  : coreutils-8.4-31.el6_5.2.x86_64                                               2/2

Failed:
  coreutils.x86_64 0:8.4-31.el6                 coreutils.x86_64 0:8.4-31.el6_5.2

Complete!
  • Have you got enough memory and disk space? – Michael Hampton Aug 30 '14 at 12:06
  • I have got 80gb fre disk space and 10gb free memory – Emrah Özdemir Aug 30 '14 at 12:16
  • 1
    problem solved with "chattr -i /bin/cat" – Emrah Özdemir Aug 30 '14 at 12:59
0

As per comment, problem solved with:

chattr -i /bin/cat
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.