2

I'm managing 10 developer computers and I want to assign to each computer a Network Drive (Let's say X: drive) so the developer can map the TFS workspace to that drive.

When the user tries to open any visual studio solution form drive X: (which's a network drive) visual studio warns the user for opening from Network solution.

I tried to give Full Trust to the network drive with 3 different ways with no luck:

1- Using CasPol (Drive)

%WINDIR%\Microsoft.NET\Framework\v2.0.50727\CasPol.exe -pp off -m -ag 1.2 -url file://X:\* FullTrust
%WINDIR%\Microsoft.NET\Framework\v4.0.30319\CasPol.exe -pp off -m -ag 1.2 -url file://X:\* FullTrust
%WINDIR%\Microsoft.NET\Framework64\v2.0.50727\CasPol.exe -pp off -m -ag 1.2 -url file://X:\* FullTrust
%WINDIR%\Microsoft.NET\Framework64\v4.0.30319\CasPol.exe -pp off -m -ag 1.2 -url file://X:\* FullTrust

2- Using CasPol (UNC)

%WINDIR%\Microsoft.NET\Framework\v2.0.50727\CasPol.exe -pp off -m -ag 1.2 -url file://\\UNC\* FullTrust
%WINDIR%\Microsoft.NET\Framework\v4.0.30319\CasPol.exe -pp off -m -ag 1.2 -url file://\\UNC\* FullTrust
%WINDIR%\Microsoft.NET\Framework64\v2.0.50727\CasPol.exe -pp off -m -ag 1.2 -url file://\\UNC\* FullTrust
%WINDIR%\Microsoft.NET\Framework64\v4.0.30319\CasPol.exe -pp off -m -ag 1.2 -url file://\\UNC\* FullTrust

3- Network (Intranet Zone)

From Internet Options -> Security -> Local Intranet -> Sites -> Advanced I added the drive

Visual Studio keeps warn the users regarding untrusted zone.

Please advice.

Thanks

3
  • 1
    Have you tried without the file:// prefix? -url X:\* Aug 30, 2014 at 16:14
  • Can you explain why do they want this? Having developers working on the same physical file is against using any version control in a sense. Knowing the scenario can help us giving better suggestions. Aug 31, 2014 at 16:18
  • Developers are not working on the same physical file, we have network driver for each developer.
    – Sameh
    Sep 1, 2014 at 9:27

2 Answers 2

4

I had the same issue when compiling projects from a network drive which contained T4 templates.

I had to add the unc path to the trusted sites. Internet Options -> Security -> Trusted sites -> Sites.

Add file://MyRemoteUncPath and make sure you uncheck Require service verification just below.

1
  • This is a much better solution than disabling the warning.
    – mrtumnus
    Sep 17, 2020 at 21:25
4

Visual Studio keeps warn the users regarding untrusted zone.

This is Visual Studio behaving. You can tell Visual Studio to stop that nonsense.

Disable this by unchecking the option at Tools → ⚙ Options…Projects and SolutionsWarn user when the project location is not trusted.

1
  • Disabling the warning is less helpful than actually whitelisting the site. See this answer
    – mrtumnus
    Sep 17, 2020 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.