I was trying to install ubuntu 14. onto a usb stick. It booted fine from the USB and I went through the process for a while until I got to the partitioning bit, I was thinking maybe the install was in memory because it gave me the option of partitioning the USB I had booted off (and the install was on), didn't think it would work but I clicked 'YES' anyway and after a second it came back and said it wasn't possible. So I escaped and exited the install through the menu, and since then I can't boot from any USB devices.

The only change I noticed was that originally the USB device was listed in the BIOS separately from the HDD under 'Boot Device Priority' like so:

  1. USB Flash Drive
  2. HDD0 blah
  3. Network Boot

but now it just shows up with one of either HDD or USB, and the second menu on the boot screen in the BIOS controls which will boot (called 'Hard Disk Drives').

Not sure that is relevant, but I thought it was weird.

What ever I try, different orders, diff 'USB Boot Priority High/Low' etc nothing works. If I disable everything except the USB drive it still boots off the HDD.

If I remove the HDD, I then get the grub error:

grub error no such device entering recovery mode
  • 1
    I think this question should be migrated to askubuntu. – kasperd Aug 30 '14 at 22:50

Clicking YES to that option has FUBAR'd the USB stick's bootability.

You will need to repeat the steps you took to create a bootable USB.

During start-up, the BIOS detects any bootable drives that are curently present, and shows those drives in the boot menu. Once your USB is bootable, it will show up again in the boot menu.


I have been through all of that myself when installing Ubuntu 12.04.

I am pretty sure your install got far enough to overwrite parts of the boot loader or the partition table on the USB media, and this is why the BIOS doesn't show it like a usual boot device, and this is why it doesn't get anywhere if you somehow force the BIOS to boot from the USB media.

You need to write the installer image to the USB media again and start over.

The thing I had to do in order to make this work with 12.04 was that when the installer was booting from the USB media, I had to enter the GRUB command line and add toram.

I also tried a typing LIVEMEDIA=/dev/sda1 instead of toram, that however did not work. It mostly worked, but failed towards the end of the install process and left me with an unbootable system.

With toram I managed to install 12.04 from a USB stick onto the very same USB stick. This does require sufficient RAM in order to work. I have 4GB, but I guess it could have worked with 2GB, I don't think it will work with only 1GB of RAM.

I don't know if any of this has changed in 14.04, because all my 14.04 systems were upgraded from earlier versions, I never installed 14.04 from scratch.

I have run into a major issue with suspend when the root device is on USB, but I managed to work around it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.