7

Is there are way to force Windows 2008R2 DHCP Server to update all DNS entries for all current leases?

(Guess the server-side equivalent of ipconfig /registerdns)

We had a configuration issue with our dynamic DNS and DNS is badly out of sync with the current leases. It's taking days to catch up now that we've fixed (I think) the original issue.

  • How long is your current scope lease time? It might be easier to drop your scope lease time really low, then delete all the dynamic DNS records and let them get re-created. If you're waiting on DNS scavenging, there's no fast way to do it. Just let it ride until you're seeing id 2501 events in the DNS Server event logs. – jscott Sep 1 '14 at 2:34
  • @jscott Bugger. The problem was our lease time vs the scavenging time. The lease is set to 8 days now which seems to be the "recommended" timeframe. – fukawi2 Sep 1 '14 at 4:04
4

I'm afraid that you're going to have to approach this from the client end. Changing the timeouts is only going to help clients the next time they check in, which is usually after half the existing lease time, or sometimes during boot. You can approach this by manually forcing the clients to check in. You might be able to do this by tweaking some group policy settings, or by running a script to bulk "ipconfig /registerdns" on a bunch of clients.

If you insist on doing this from the server end of things, it should be possible to write a custom program to read the entries from a DHCP lease export, and register the addresses, but be sure to run it as the same account that DHCP uses for registrations, or else it may have trouble updating the entries in the future.

| improve this answer | |
1

One of the way you can do this is by enabling DNS Aging/scavenging.

Please Backup your DNS and DHCP!

You will have to make changes in 2 places:

  1. DNS SERVER [Enable aging/scavenging for all zones]

    -Open you DNS server and open your zones

    -Right Click > Properties > General Tab >Aging

    -Check the "Scavenge stage resource records" -Change the No-refresh interval and Refresh interval from days to hours

Note: Don't forget to change it back to a appropiate interval when the dns is updated and you must take another step in DHCP server for this to work.

DNS Image 2. DHCP SERVER [Check DNS update settings for all scopes]

  • Open your DHCP server and click down to the scopes

  • Right click on your scope > Click Properties > DNS Tab

  • Take a note of your current settings and apply the highlighted settings from the image below

DHCP Image

Note: Please backup your dns and dhcp before changing anything. This should bring your DHCP/DNS up to date

| improve this answer | |
  • This won't force an immediate "sync" between the DHCP and DNS systems, I still have to wait X days for scavenging etc to take place. – fukawi2 Mar 9 '15 at 23:36
  • 1
    Another Place to check will be DHCP > "Right Click" IPv4 > Properties > Advanced > Credentials > Input credentials with admin access to DNS service. This will ensure that dhcp can update dns records. Then try ipconfig /registerdns – zman Mar 10 '15 at 2:41
0

Theoretically, there is message type DHCPFORCERENEW, described in RFC 3203, that was created for this purpose. But it has not been widely implemented in clients. Clients would need to implement DHCP authentication to prevent rogue DHCPFORCERENEW messages disconnecting clients.

You could disable and re-enable ports on your switch, if you have a suitable managed switch. Or, physically unplug and reconnect clients at your switch.

| improve this answer | |
  • I don't see Windows currently supporting DHCPFORCERENEW, and it's probably not high on Microsoft's list. The switch port manipulation is a clever solution though that should be possible with an appropriate level of scripting :) – fukawi2 Feb 20 at 0:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.