0

During a puppet run, ia32-libs was installed, this seems to have caused several packages to be uninstalled but I'm not sure why.. Can anyone shine any light on the matter?

Here's the apt log entry:

Start-Date: 2014-09-01  09:59:18
Commandline: /usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install ia32-libs
Install: libopenal1:i386 (1.14-4), sane-utils:amd64 (1.0.22-7.4, automatic), libedit2:i386 (2.11-20080614-5), libkrb5-3:i386 (1.10.1+dfsg-5+deb7u2, automatic), libpam0g:i386 (1.1.3-7.1), libts-0.0-0:i386 (1.0-11, automatic), libk5crypto3:i386 (1.10.1+dfsg-5+deb7u2, automatic), libpopt0:i386 (1.16-7), libstdc++5:i386 (3.3.6-25), libstdc++6:i386 (4.7.2-5, automatic), libxfixes3:i386 (5.0-4+deb7u1, automatic), uuid-runtime:amd64 (2.20.1-5.3, automatic), libxcomposite1:i386 (0.4.3-2), libldap-2.4-2:i386 (2.4.31-1+nmu2, automatic), libgphoto2-l10n:amd64 (2.4.14-2, automatic), libv4l-0:amd64 (0.8.8-3, automatic), libv4l-0:i386 (0.8.8-3, automatic), liblcms1:i386 (1.19.dfsg-1.2), ia32-libs-i386:i386 (0.4), libgphoto2-port0:amd64 (2.4.14-2, automatic), libgphoto2-port0:i386 (2.4.14-2, automatic), libidn11:i386 (1.25-2, automatic), libnss3:i386 (3.14.5-1+deb7u1, automatic), libwrap0:i386 (7.6.q-24, automatic), libcaca0:i386 (0.99.beta18-1, automatic), libfile-copy-recursive-perl:amd64 (0.38-1, automatic), libsamplerate0:i386 (0.1.8-5, automatic), libacl1:i386 (2.2.51-8), libcomerr2:i386 (1.42.5-1.1), libselinux1:i386 (2.1.9-5), libjpeg8:i386 (8d-1+deb7u1, automatic), ia32-libs:amd64 (0.4), libsvga1:i386 (1.4.3-33), libdrm-radeon1:i386 (2.4.40-1~deb7u2, automatic), libdbus-1-3:i386 (1.6.8-1+deb7u3, automatic), libaio1:i386 (0.3.109-3), libsane:amd64 (1.0.22-7.4, automatic), libsane:i386 (1.0.22-7.4), odbcinst1debian2:amd64 (2.2.14p2-5, automatic), odbcinst1debian2:i386 (2.2.14p2-5), update-inetd:amd64 (4.43, automatic), libtinfo5:i386 (5.9-10, automatic), libxxf86vm1:i386 (1.1.2-1+deb7u1, automatic), libcap2:i386 (2.22-1.2), libgl1-mesa-dri:i386 (8.0.5-4+deb7u2, automatic), libtdb1:i386 (1.2.10-2), libxcb-glx0:i386 (1.8.1-2+deb7u1, automatic), libgl1-mesa-glx:i386 (8.0.5-4+deb7u2, automatic), libx86-1:i386 (1.1+ds1-10, automatic), libjack-jackd2-0:i386 (1.9.8~dfsg.4+20120529git007cdc37-5), libxslt1.1:i386 (1.1.26-14.1), libnspr4-0d:i386 (4.9.2-1+deb7u2), libx11-xcb1:i386 (1.5.0-1+deb7u1, automatic), libgnutls26:i386 (2.12.20-8+deb7u2, automatic), libglapi-mesa:i386 (8.0.5-4+deb7u2, automatic), libopenal-data:amd64 (1.14-4, automatic), odbcinst:amd64 (2.2.14p2-5, automatic), libjbig0:i386 (2.0-2+deb7u1), libbsd0:i386 (0.4.2-1), libsigc++-2.0-0c2a:i386 (2.2.10-0.2), libxmuu1:i386 (1.1.1-1), libtasn1-3:i386 (2.13-2, automatic), libfreetype6:i386 (2.4.9-1.1, automatic), libexpat1:i386 (2.1.0-1+deb7u1, automatic), libv4lconvert0:amd64 (0.8.8-3, automatic), libv4lconvert0:i386 (0.8.8-3, automatic), liblzma5:i386 (5.1.1alpha+20120614-2, automatic), libdirectfb-1.2-9:i386 (1.2.10.0-5), libavahi-common-data:i386 (0.6.31-2, automatic), libc6-i686:i386 (2.13-38+deb7u4, automatic), acl:amd64 (2.2.51-8, automatic), libncursesw5:i386 (5.9-10, automatic), libffi5:i386 (3.0.10-3, automatic), libjson0:i386 (0.10-1.2, automatic), libgcc1:i386 (4.7.2-5, automatic), libxcb1:i386 (1.8.1-2+deb7u1, automatic), libp11-kit0:i386 (0.12-3, automatic), libdrm2:i386 (2.4.40-1~deb7u2, automatic), libxau6:i386 (1.0.7-1, automatic), libsdl1.2debian:i386 (1.2.15-5), libxaw7:i386 (1.0.10-2), libgdbm3:i386 (1.8.3-11), libcups2:i386 (1.5.3-5+deb7u4), libcurl3:i386 (7.26.0-1+wheezy9), libfltk1.1:i386 (1.1.10-14), libxinerama1:i386 (1.1.2-1+deb7u1, automatic), libesd0:i386 (0.2.41-10+b1), libkrb5support0:i386 (1.10.1+dfsg-5+deb7u2, automatic), libxft2:i386 (2.3.1-1, automatic), libssh2-1:i386 (1.4.2-1.1, automatic), libdrm-nouveau1a:i386 (2.4.40-1~deb7u2, automatic), libice6:i386 (1.0.8-2, automatic), libxdmcp6:i386 (1.1.1-1, automatic), libieee1284-3:amd64 (0.2.11-10, automatic), libieee1284-3:i386 (0.2.11-10), libgcrypt11:i386 (1.5.0-5+deb7u1, automatic), libdrm-intel1:i386 (2.4.40-1~deb7u2, automatic), libxml2:i386 (2.8.0+dfsg1-7+wheezy1), libkeyutils1:i386 (1.5.5-3, automatic), lesstif2:i386 (0.95.2-1.1), liblzo2-2:i386 (2.06-1+deb7u1), libxmu6:i386 (1.1.1-1, automatic), libgpm2:i386 (1.20.4-6, automatic), libvorbisfile3:i386 (1.3.2-1.3), libsane-common:amd64 (1.0.22-7.4, automatic), esound-common:amd64 (0.2.41-10, automatic), libasound2:i386 (1.0.25-4, automatic), libxpm4:amd64 (3.5.10-1, automatic), libxpm4:i386 (3.5.10-1, automatic), libflac8:i386 (1.2.1-6), libusb-0.1-4:i386 (0.1.12-20+nmu1, automatic), libxrender1:i386 (0.9.7-1+deb7u1, automatic), libnspr4:i386 (4.9.2-1+deb7u2, automatic), libvorbisenc2:i386 (1.3.2-1.3, automatic), zlib1g:i386 (1.2.7.dfsg-13, automatic), libasyncns0:i386 (0.8-4), libxss1:i386 (1.2.2-1), libgd2-xpm:amd64 (2.0.36~rc1~dfsg-6.1, automatic), libgd2-xpm:i386 (2.0.36~rc1~dfsg-6.1, automatic), libtiff4:i386 (3.9.6-11, automatic), libpng12-0:i386 (1.2.49-1, automatic), libjpeg62:i386 (6b1-3+deb7u1), libpciaccess0:i386 (0.13.1-2, automatic), gcc-4.7-base:i386 (4.7.2-5, automatic), libxtst6:i386 (1.2.1-1+deb7u1, automatic), libsane-extras:amd64 (1.0.22.2, automatic), libsane-extras:i386 (1.0.22.2, automatic), libuuid1:i386 (2.20.1-5.3, automatic), tsconf:amd64 (1.0-11, automatic), libavahi-client3:i386 (0.6.31-2), libmpg123-0:i386 (1.14.4-1), libsysfs2:i386 (2.1.0+repack-2), libx11-6:i386 (1.5.0-1+deb7u1, automatic), libsasl2-2:i386 (2.1.25.dfsg1-6+deb7u1, automatic), libdb5.1:i386 (5.1.29-5, automatic), libfontconfig1:i386 (2.9.0-7.1, automatic), xaw3dg:i386 (1.5+E-18.2), libsm6:i386 (1.2.1-2, automatic), libpulse0:i386 (2.0-6.1, automatic), libxdamage1:i386 (1.1.3-2, automatic), libsane-extras-common:amd64 (1.0.22.2, automatic), libxcb-render0:i386 (1.8.1-2+deb7u1, automatic), libodbc1:i386 (2.2.14p2-5), libexif12:amd64 (0.6.20-3, automatic), libexif12:i386 (0.6.20-3), libglu1-mesa:i386 (8.0.5-4+deb7u2), librtmp0:i386 (2.4+20111222.git4e06e21-1, automatic), libgssapi-krb5-2:i386 (1.10.1+dfsg-5+deb7u2, automatic), libxi6:i386 (1.6.1-1+deb7u1, automatic), libvorbis0a:i386 (1.3.2-1.3, automatic), libc6:i386 (2.13-38+deb7u4, automatic), libattr1:i386 (2.4.46-8, automatic), libxp6:i386 (1.0.1-2+deb7u1, automatic), libaudio2:i386 (1.9.3-5wheezy1), libxcursor1:i386 (1.1.13-1+deb7u1), libxt6:i386 (1.1.3-1+deb7u1, automatic), libxv1:i386 (1.0.7-1+deb7u1), libslang2:i386 (2.2.4-15, automatic), libxext6:i386 (1.3.1-2+deb7u1, automatic), libsasl2-modules:i386 (2.1.25.dfsg1-6+deb7u1, automatic), libavahi-common3:i386 (0.6.31-2, automatic), libxcb-render-util0:i386 (0.3.8-1.1), libxrandr2:i386 (1.3.2-2+deb7u1), libnss3-1d:i386 (3.14.5-1+deb7u1), freeglut3:i386 (2.6.0-4), libsndfile1:i386 (1.0.25-5, automatic), libsqlite3-0:i386 (3.7.13-1+deb7u1, automatic), libltdl7:amd64 (2.4.2-1.1, automatic), libltdl7:i386 (2.4.2-1.1, automatic), libssl1.0.0:i386 (1.0.1e-2+deb7u12, automatic), libgpg-error0:i386 (1.10-3.1, automatic), libgphoto2-2:amd64 (2.4.14-2, automatic), libgphoto2-2:i386 (2.4.14-2), libogg0:i386 (1.3.0-4, automatic), libaudiofile1:i386 (0.3.4-2)
Upgrade: libkrb5-3:amd64 (1.10.1+dfsg-5+deb7u1, 1.10.1+dfsg-5+deb7u2), libk5crypto3:amd64 (1.10.1+dfsg-5+deb7u1, 1.10.1+dfsg-5+deb7u2), openssh-server:amd64 (6.0p1-4+deb7u1, 6.0p1-4+deb7u2), libc-bin:amd64 (2.13-38+deb7u1, 2.13-38+deb7u4), libgnutls26:amd64 (2.12.20-8+deb7u1, 2.12.20-8+deb7u2), libcups2:amd64 (1.5.3-5+deb7u2, 1.5.3-5+deb7u4), libkrb5support0:amd64 (1.10.1+dfsg-5+deb7u1, 1.10.1+dfsg-5+deb7u2), openssh-client:amd64 (6.0p1-4+deb7u1, 6.0p1-4+deb7u2), libxml2:amd64 (2.8.0+dfsg1-7+nmu3, 2.8.0+dfsg1-7+wheezy1), libc6-dev:amd64 (2.13-38+deb7u1, 2.13-38+deb7u4), openssl:amd64 (1.0.1e-2+deb7u11, 1.0.1e-2+deb7u12), libgssapi-krb5-2:amd64 (1.10.1+dfsg-5+deb7u1, 1.10.1+dfsg-5+deb7u2), libc-dev-bin:amd64 (2.13-38+deb7u1, 2.13-38+deb7u4), libc6:amd64 (2.13-38+deb7u1, 2.13-38+deb7u4), libssl1.0.0:amd64 (1.0.1e-2+deb7u9, 1.0.1e-2+deb7u12)
Remove: ruby1.8-dev:amd64 (1.8.7.358-7.1+deb7u1), postgresql-9.2:amd64 (9.2.4-1+we7.wheezy.1), postgresql-9.3:amd64 (9.3.4-1~bbm.1.wheezy), bind9-host:amd64 (9.8.4.dfsg.P1-6+nmu2+deb7u1), libzip-ruby1.8:amd64 (0.9.4-1), libaugeas-ruby1.8:amd64 (0.4.1-1.1), dnsutils:amd64 (9.8.4.dfsg.P1-6+nmu2+deb7u1), puppet:amd64 (2.7.23-1~deb7u3), libdns88:amd64 (9.8.4.dfsg.P1-6+nmu2+deb7u1), postgresql-contrib-9.2:amd64 (9.2.4-1+we7.wheezy.1), postgresql-contrib-9.3:amd64 (9.3.4-1~bbm.1.wheezy), munin-plugins-we7:amd64 (67+b57.ga573c7d.wheezy1), libbind9-80:amd64 (9.8.4.dfsg.P1-6+nmu2+deb7u1), postgresql-client-9.2:amd64 (9.2.4-1+we7.wheezy.1), postgresql-client-9.3:amd64 (9.3.4-1~bbm.1.wheezy), libdbd-pg-perl:amd64 (2.19.2-2), libisccfg82:amd64 (9.8.4.dfsg.P1-6+nmu2+deb7u1), puppet-common:amd64 (2.7.23-1~deb7u3), libpq5:amd64 (9.3.4-1~bbm.1.wheezy), python-psycopg2:amd64 (2.4.5-1)
End-Date: 2014-09-01  09:59:43
  • A good way to debug such problems is to run the apt-get command (without -q -y) manually. Try to force installing the packages it removed as well as ia32-libs and it should tell you what conflicts with what. – András Korn Sep 2 '14 at 20:54
  • I would try that but the removed packages have now been added back and are now co-existing with ia32-libs.. :-/ – Gaspode Sep 3 '14 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.