0

Background:

Running Windows 2008 R2

  1. DHCP server not installed as Role
  2. Installed server as a Domain controller
  3. AD DS forest root domain = axiom-mods
  4. DNS server installed
  5. name of computer= nlb1

When I click on the start button -> Administrative Tools -> Active Directory Users and Computer. I end up with an error like the dialog box in picture shown.

enter image description here

I thought it had something to do with DNS because of what I see on the first line of the dialog box that popped up.

I have my DNS info in the background picture as well. I am running a DNS server on my domain controller. I was under the impression that I needed a DNS server to install AD DS. I did do that when I initially set up my server using DCpromo.

What happened? I remember being able to add users to the domain before?

Also, when I click on: Server Manager --> Roles --> DNS and I hover over DNS in the submenu and I see errors in event viewer, it says DNS server could not open socket to 192.168.1.100 (which is the IP address of my LAN adapter and the address I gave to my DNS server)

https://imageshack.com/i/p5zSIT2gp

Edit: Okay so I have got rid of second problem which says DNS could not open a socket to 192.168.1.100.

So i know DNS service is working. But I notice that the reverse lookup zone are missing. So, I tried to create a reverse zone lookup in DNS Manager I clicked my DNS server in the manager and right click and the submenu to create new zone for DNS wizard pops up. I cannot create the reverse lookup zone for my DNS service because I cannot create a directory partition for axiom-mods.com domain due to fact that it thinks im not Enterprise Admin.

  • As a new user you may not yet have enough reputation points to upload images, but you can include links to images posted elsewhere. – HBruijn Sep 2 '14 at 12:47
  • 1
    I've set this to close as "Unclear what you're asking" only because there are no screenshots or exact error messages. If you'll edit your question with the actual info that can assist us in answering it, I'll remove my vote. Thanks. – TheCleaner Sep 2 '14 at 13:17
  • Well, better, but insufficient. Active Directory is highly dependent on DNS to function. Your DNS isn't working properly (as evidenced by the error message that it can't open a socket), so Active Directory isn't working either. Have you tried restarting the DNS service on the server? Are you sure that address is valid for that interface? Are you sure nothing else is currently bound to the port DNS needs? Has the server's IP address changed? (And more - basically, what troubleshooting have you done?) – HopelessN00b Sep 3 '14 at 22:46
  • I have some more problems. It appears that AD DS cannot locate a global catalog. The error states "c\Active Directory Services could not connect to the global catalog. I have tried starting DNS service. There is no other address valid for the interface. I have tried to change yank out my other network adapter. I remember before everything went crazy, I added a new network adapter and yanked out my dvdrom drive. I got blue screens upon reboot. So, then I yanked everything back out(new net adapter) and put back dvd rom. I must also state that I haven't changed any configs from when last time. – Selby Chan Sep 5 '14 at 21:15
  • imgur.com/F3fkOUz – Selby Chan Sep 6 '14 at 9:21
0

Here are some troubleshooting ideas: (as I don't see your screenshot) - Install RSAT on another machine and try to open the tool (run > dsa.msc) - Open ncpa.cpl and check the dns configuration. is it set to 127.0.0.1?

fyi, you can use non microsoft dns for AD DS. Are you able to open dsa.msc from another server? Can you change the domain controller to nlb1?

  • This is the problem. I wanted to do a remote installation of another windows 2008 via WDS. But, somehow you need AD DS to function. Plus DHCP and DNS. I wanted to install a guest VM via PXE boot on my other computer running client hyper-v(Win 8.1). Everything is misconfigured for some reason. I keep seeing Active Directory, DNS server, WDS server with red error marks in my server manager. Then when i go to event viewer. I see all the errors listed above in my screen shots. – Selby Chan Sep 4 '14 at 19:55
  • ![imgur.com/F3fkOUz][4][[4] – Selby Chan Sep 6 '14 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.