1

I am starting to use the git aws.push command from within a git repository for a certain project we are currently working on. Within the root of the repo I have got the .elasticbeanstalk directory with the following configuration details:

AwsCredentialFile=Removed for Security

ApplicationName=Removed for Security

DevToolsEndpoint=git.elasticbeanstalk.eu-west-1.amazonaws.com

EnvironmentName=Removed for Security

Region=eu-west-1

Initially when I cloned my repo, the git aws.push command did not exist, so I called the AWSDevTools-RepositorySetup.sh file which solved that issue. Then when I run git aws.config, it correctly picks up the app name, endpoint, environment name and region from the config file above. It also correctly picks up the AWS access and secret keys from the referenced AwsCredentialFile.

Here's where the issue is though. When I run git aws.push, a message appears saying "Updating the AWS Elastic Beanstalk environment ENV-NAME...". This message appears for almost 20 minutes or sometimes even more and only after that does it show up "Environment update initiated successfully." I also do not see any git push log here, as in the progress log you would usually see when pushing to a git repo, which some of my colleagues are seeing.

Can anyone advise as to why this might be happening and 1, why it takes so long and 2, why I do not see the git log?

Also, just as an FYI:

  • AWS Elastic Beanstalk Command Line Interface v2.6.3

  • git version 1.8.5.2 (Apple Git-48)

Additionally, when I run eb stop, it warns me that my branch is not associated with an EB environment. However when I run eb branch or eb init, it prompts me to create a new EB environment rather than hooking up to the environment specified in my config file for some reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.