2

Im trying to setup a PXE boot server to deploy CloneZilla images easily, using pxelinux.0. I have a tftp-hpa server running on a server, I tested it with a client and it works fine. We are using a FortiNet router as the DHCP server, so I added that :

set option1 66 '3139322e3136382e302e313533'
set option2 67 '7078656c696e75782e30'

Which would translate to 192.168.0.153 for the option 66, and pxelinux.0 for option 67. I dumped the DHCP offer packets to check, and that seems to be correct. When I try to boot an empty VMware workstation VM on PXE to check however, it does receive the options, but it asks the DHCP server (192.168.0.1) for the file pxelinux.0, completely ignoring option 66. Is that somehow normal behavior ? I've seen mention of option 43 and 60, but I understood it's used only for Microsoft environments. Maybe I'm supposed to set those options to something anyway to make the option 66 used ?

1

Figured out a way to make it work. It looks like the option 66 isn't actually used by anyone, instead the next-server part of the protocol is used. Unfortunately, I can't change it on my version of the Fortinet firmware, it's automatically set to it's own address, so I added a policy to redirect traffic coming to port 69 (tftp) of the fortinet to the actual TFTP server, and it works perfectly. That's not a great solution, but at least it works.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.