0

i have installed snmp, utils using

yum install net-snmp

yum install net-snmp-utils

This is my /etc/snmp/snmpd.config

syslocation System Location
syscontact email@a.com
#      sec.name   source          community (password) 
com2sec Mybox     localhost          public 
com2sec Outside   default            public 
#      group.name sec.model  sec.name 
group   RWGroup    v2c       Mybox 
group   ROGroup    v2c       Outside 
view all     included  .1        80 
view system  included  system    fe 
#              context sec.model sec.level prefix  read    write  notif 
access  ROGroup   ""      any    noauth    exact   all     none   none 
access  RWGroup   ""      v2c    noauth    exact   all     all    all 

SNMP WALK works locally (localhost and 10.106.240.138-my static IP)

snmpwalk -v2c -c public 10.106.240.138:161

Whereas it doesnt work from a remote Linux system (say 10.106.240.179 - same network)

Timeout: No Response from 10.106.240.138:161

iptables,ip6tables(firewall) have been disbaled

I have tried with a simpler snmpd.conf configuration too !

rocommunity public syslocation "EARTH" syscontact user@domain.com

Help me! what am I missing !!

EDIT 1

Hi, i found the /etc/sysconfig/snmp file and added the OPTIONS config to it to allow my SNMP client IP

OPTIONS="-Lsd -Lf /dev/null -p /var/run/snmpd.pid -a -x 10.106.240.179"

It still doesnt work !

This is my SNMP service status

snmpd.service - Simple Network Management Protocol (SNMP) Daemon. Loaded: loaded (/usr/lib/systemd/system/snmpd.service; enabled) Active: active (running) since Fri 2014-09-05 02:47:42 IST; 5s ago Main PID: 21847 (snmpd) CGroup: /system.slice/snmpd.service └─21847 /usr/sbin/snmpd -Lsd -Lf /dev/null -p /var/run/snmpd.pid -a -x 10.106.240.179 -f

Any input would be appreciated, thanks !

Do I have to configure the remote client ?

0

Check that the daemon is not listening on localhost only. This should be specified in /etc/sysconfig/snmpd.options (I don't remember exactly).

  • Hi unlink, i have made the changes and updated the question, pls let me know if you can figure out any problem? Thanks! – GP cyborg Sep 5 '14 at 5:44
  • You configured the server to listen on the client IP address: OPTIONS="-Lsd -Lf /dev/null -p /var/run/snmpd.pid -a -x 10.106.240.179". Change the line to the server address: OPTIONS="-Lsd -Lf /dev/null -p /var/run/snmpd.pid -a -x 10.106.240.138" or completely remove the -x option. – unlink Sep 5 '14 at 9:16
  • i uncommented the line ` OPTIONS="-LS0-6d -Lf /dev/null -p /var/run/snmpd.pid"` but it still does not work. however it does work locally only. – shorif2000 Mar 23 '15 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.