0

I am working on a POC of Beeswarm and I'm running into an issue with connecting the drone. For the basic setup, I have the server working fine and I can access it via https://X.X.X.X:5000 (I get a certificate error due to accepting the defaults). When I setup another server on the same subnet, I run the following command and get an error.

user@beeswarm-sensor1:/opt/drone_workdir$ sudo beeswarm --config https://X.X.X.X:5000/ws/drone/add/0f74fe
2014-09-03 16:12:24,681 (root) Initializing BeeSwarm version 0.4.17
2014-09-03 16:12:24,688 (requests.packages.urllib3.connectionpool) Starting new HTTPS connection (1): 10.6.13.238
/usr/local/lib/python2.7/dist-packages/requests/packages/urllib3/connectionpool.py:730: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.org/en/latest/security.html (This warning will only appear once by default.)
  InsecureRequestWarning)
2014-09-03 16:12:24,704 (root) Error while extracting configuration from https://X.X.X.X:5000/ws/drone/add/0f74fe, please make sure that the correct url was provided.

I'm assuming this is due to the certificate error but I don't see any reference on Beeswarm's documentation that this is an issue for anyone else. Since this is just a quick POC I didn't want to deal with creating certs and whatnot.

Thanks, Eric

  • Have you seen this line: please make sure that the correct url was provided? Try to access that URL on your browser to see if it is correct. – ThoriumBR Sep 4 '14 at 13:48
  • It looks like it's a database error on the Beeswarm server. After calling a default.py script I get an OpertaionalError that says "attempt to write a readonly database". – Eric Sep 4 '14 at 15:58
  • I am the lead developer on the Beeswarm project, if you can reproduce these errors - could you please raise them as issues on our github page(github.com/honeynet/beeswarm/issues)? – Johnny Sep 4 '14 at 20:06
  • The issue was that I did "sudo mkdir /opt/server_workdir" and then I ran "sudo beeswarm --server" from the /opt/server_workdir. Since I did everything as sudo, there seemed to be some weird permissions issues and it didn't like writing to the database. Once I did a normal mkdir and run as a non-privileged user, it worked fine. – Eric Sep 4 '14 at 20:42
0

I believe the issue was due to my running beeswarm under sudo. Once I ran it as a non-privileged user it worked fine. I apologize for the post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.