0

I'm currently testing Windows 7 x64 within our business ahead of finally moving all computers off of Windows XP.

Everything seemed to go swimmingly until recently my desktop has been unable to connect to printers managed by our print management server, which is a Server 2003 R2 machine (the sole-remaining one, also our TS, awaiting upgrade).

The printers are usually deployed via Group Policy to the computers in certain OUs.

I can find the printers either by connecting to the management servers UNC or using Devices & Printers > Add a Printer, but trying to Connect gives me a 'Windows cannot connect to the printer - Operation failed with error 0x00000006' error.

'Opening' the printer gives a slight different 'No Printers were found' error, with no error code.

I can connect to the printer via it's IP address and I can connect to shared USB printers via device UNCs - it's just not the printer shares from the Print Management server.

I have undertaken the activity here - http://community.spiceworks.com/topic/post/3418990 - but this (sometimes) only resolves the problem until the next boot, so it's hardly a long-term solution for 100 computers.

I have tried resolving the problem with UAC disabled and Network Discovery on. I have installed both 32 & 64-bit drivers on the print server.

I have recently installed McAfee VSE 8.8 onto the server as part of our companies roll-out, but I'm not seeing any blocked actions in the log files (although I am open to creating exceptions, if people know of anything relating to this).

Also, Windows XP machines are still receiving their printer deployments from the server and can connect at will to the shares.

  • Do you have the x64 drivers installed on your print server? I ran into this problem before as well back when I had a print server on 2003. – Nathan C Sep 4 '14 at 13:51
  • I have mentioned that in the body of the article. Also, Windows 7 would just go and get the driver if it was not. Something (either the server or the desktop) is simply refusing to let the connection happen! – Optimaximal Sep 4 '14 at 13:54
  • Ah, I see it now. It appears to be a client-side rendering problem from what I've been reading. If you disable this and let the print server render the jobs, it might go away. It appears to only happen with certain drivers with Windows 7. – Nathan C Sep 4 '14 at 14:06
  • I've enabled the Group Policy 'Always render print jobs on the server' but it's made no difference. The problem isn't that I cannot print, it's that the W7 computer cannot connect to the 2003 Printer Shares. – Optimaximal Sep 4 '14 at 14:48
  • Did you happen to see this SpiceWorks registry edit suggestion? – Kate Sep 4 '14 at 21:35
0

Unfortunately, the only reliable solution I could find was to migrate the Document and Print Management Services to a 2008 R2 server. I've had no problems since.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.