0

I have a Win2008r2 box with terminal services, and I'd like to connect with RDP6.1 from a Win7 box, and play sounds on the server. I've configured the remote desktop host to allow audio redirection, and I've changed the client's connection parameters to "Leave audio on server", but whenever I connect I still get "No audio device output device is installed" thrown at me.

Any clues?

  • What is the purpose of this? I'm just curious. I have such a server playing sound locally through a service:ified winamp that works fine even when I RDP to it... as long as the service runs under another account... – Oskar Duveborn Nov 26 '09 at 13:32
1

See also: http://social.technet.microsoft.com/Forums/en/winserverTS/thread/2b65bfc3-89b9-4d0b-8244-7d02081a1f03?prof=required

Leave at remote computer has the same effect as Do not Play. Unfortunately there is no work around.

1

By default audio redirection is disabled on server side

To enable it, run tsconfig.msc on server, double click the connection, go to “Client Settings” tab, uncheck the “Audio” checkbox.

0

I see that it's commented on in the technet forums: social.technet.microsoft.com/Forums/en-US/… - "Yes this is a change from WS2003 to WS2008. Leave at remote computer has the same effect as Do not Play. Unfortunately there is no work around." But seriously ... There has to be a workaround, even if it involves binary patching Microsoft's audio endpoint builder, the audio service or remote desktop host!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy