0

I'm having a hard time figuring out how to get rid of "www" in the url.

I am looking for giving access to the website when you type down mywebiste.co as well as redirecting www.mywebsite.co to mywebsite.co

I have tried through apache2, in the configuration files and create a virtual host but that didn't work from the tutorial I used.

I'm thinking maybe I have to configure something else with AWS ? I don't really know what to look for to be honest. therefore my post here.

I own the domain name with GoDaddy, and use Route 53 and EC2 on AWS to have my servers set up.

You can try it here : www.meetmyfriends.co

Many thanks.

  • 2
  • Thank you Michael, I appreciate your advice. How do I redirect no-www to www ? I you look at meetmyfriends.co you will se there is absolutely nothing at this page and I don't know how to address this issue. I'be been trying to set up virtual host on apache without success. Many Thanks – Miles M. Sep 8 '14 at 21:04
  • 1
    The link shows you how to configure Route 53 for it. Setting up the virtual host would be a separate question. – Michael Hampton Sep 8 '14 at 21:08
  • 1
    I want to make sure I understand what you are trying to do. Are you trying to setup a redirect for www.meetmyfriends.co to meetmyfriends.co or trying to get meetmyfriends.co to point to your web server? The reason I ask is when I do a DNS lookup for meetmyfriends.co, it does not look like it has an A record configured. This would cause meetmyfriends.co not to work. – imperalix Sep 8 '14 at 21:08
  • So I don't know if I'm doing it wrong with the virtual host configuration or if this is something that should be handled with AWS somehow ? Route 53 manages "meetmyfriends.co." which seems to be ok with no-www .. ? – Miles M. Sep 8 '14 at 21:09
2

Sounds like you need to create an A record for meetmyfriends.co. To do this, inside of your zone do the following.

  1. Click Create Record Set
  2. Leave Name empty
  3. Ensure type is set to A
  4. In the value section enter 54.214.246.243
  5. Click create.
  • Wow that was it, verrry simple thank you so much ! – Miles M. Sep 11 '14 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.