0

04 TLS server with iRedMail installed. When just installed it worked okay but after 4 emails I get a error message

Sep 9 12:24:18 hostname postfix/smtp[9907]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused Sep 9 12:24:18 hostname postfix/smtp[9907]: D97C720A31: to=, relay=none, delay=1.1, delays=1.1/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused) Sep 9 12:24:19 hostname postfix/smtpd[9892]: disconnect from localhost[127.0.0.1]

I don't know where the problem is. Can someone help me out here?

2

I ran into something similar recently. In my case, scanning the logs I noticed some memory allocation errors and this, together with some hints from pages, suggested to me that the node didn't have enough RAM to operate properly. I've subsequently added 1GB of swap which seems to have helped. So I'd tentatively suggest it's a low memory condition -- add some RAM and reboot and see if things improve, and look through your logs for errors.

-1

Run postmap command on conf files in /etc/postfix/ and restart postfix service.

  • 1
    There is no indication in the post that would suggest this to be a problem. – Sven Feb 19 '15 at 22:30
  • 1. The postfix smtpd daemon isn't working. It is refusing connections. 2. Postfix loads its configuration into lookup tables. The can become corrupted if changes are made to the config when Postfix is running, resulting in service errors. 3. The postmap command re-creates the lookup tables based on the config in /etc/postfix – Garreth McDaid Feb 20 '15 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.