There is a linux server supporting NFS v3 and 4, and a virtual machine with WinXP running a client service for NFS. XP can ping the server, but cannot mount NFS shares.

From /etc/exports:

/home/files     ,all_squash,anonuid=1003,anongid=1003,insecure,no_subtree_check)

--debug option is passed to nfsd, but no corresponding output in /var/log/messages was seen. Looks like requests didn’t come to the server at all.

On windows when I run

mount\home\files Z:

I got

ERROR — Invalid command line argument
mount\home\files Z:

If I go with

net use Z:\home\files

It throws

System error 67 has occurred. 
The network name cannot be found.

After small change in address

net use Z: \\\home\files

It skips for a second then gives another error:

System error 1231 has occurred.
The network location cannot be reached. For information about network troubleshooting, see Windows Help.

According to the digital signature and the last mod time of the ‘UNIX services’ downloaded, they’re presumably of 2003–2004 year. The Linux kernel running the server is new—3.10, so there might be a some kind of incompatibility. However, NFS v4 was released yet in the December 2000, so I’m not sure. I’ve tried to disable windows’s firewall, but with no luck. The server shouldn’t be blocking any ports for the NAT.

  • did you try to map through windows explorer to the location \\ – user16081-JoeT Sep 10 '14 at 0:27
  • @user16081-JoeT I’ve tried to RMB on ‘My Computer’ → Add new remote volume… (or something like that, the system interface is localized, and I can’t find how to switch it to English, sadly), then after suggested Z: letter I enter \\\home\files; two windows appear next: one indicating search process nad the other with error ‘Couldn’t find remote folder.’ – tijagi Sep 10 '14 at 10:07
  • did you try without the path \home\files ? If it's accessible at all, windows should present you with a folder (\home, ideally) that you could then click on and see if there's an error or prompt or what... – user16081-JoeT Sep 10 '14 at 15:30
  • @user16081-JoeT how will that work if the /home isn’t exported? I can guarantee, that the share is set up well, because other VMs in the network accessing it without problems. They’re linux, though. – tijagi Sep 10 '14 at 15:36
  • Running NFS on Windows is looking for trouble. Better to install Samba on this Linux server and mount over SMB. – Giovanni Tirloni Sep 12 '14 at 14:10

Try executing the following command
mount Z:

This should work for you.

If you want to mount the root folder, then execute the command
mount! Z:

PS: As for why this works, have no idea, I am a total NFS noob... If anyone knows please share it in the comments.

  • 1
    While this might answer the question, we generally appreciate some explanation as to why and how. – Falcon Momot Nov 4 '14 at 6:24
  • 1
    mount command comes from a windows feature called nfs-client (that may be enabled from powershell by install-windowsfeature nfs-client command). – user246890 Sep 18 '17 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.