1

I'd like to set xfs quota on my CentOS 6 server, so I installed xfsprogs package. However it says command limit not found as shown below.

[root@myserver ~]# xfs_quota

xfs_quota> print
Filesystem          Pathname
/vol1               /dev/sda1 (uquota, gquota)
/vol2               /dev/sdb1 (uquota, gquota)

xfs_quota> help limit
command limit not found

xfs_quota> ?
df [-bir] [-hn] [-f file] -- show free and used counts for blocks and inodes
help [command] -- help for one or all commands
print -- list known mount points and projects
quit -- exit the program
quota [-bir] [-gpu] [-hnNv] [-f file] [id|name]... -- show usage and limits

Use 'help commandname' for extended help.

Although I execute the command as root, administratior commands are not available.

Am I missing something?

  • What is the expected behaviour, and why? – 200_success Sep 10 '14 at 3:41
  • The limit command should be the way to set quota, but I cannot use it so far because it's missing. At least, help limit should output the extended help. – kjtanaka Sep 10 '14 at 4:11
0

Maybe just the help is lacking the documentation for limit? Did you try something like xfs_quota -x -c "limit -u bsoft=100m bhard=120m someuser" already?

  • Thank you, Janne. The -x option was what I was missing. – kjtanaka Sep 12 '14 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.