4

I'm trying to add an FTP account to a Website that I've setup in IIS7.

Here's what I've done so far (following these instructions):

  • added the windows account 'newFTP'
  • found the site in IIS Manager and clicked 'Add FTP Publishing...'
    • IP:unasigned
    • Port: 21
    • checked 'Enable Virtual Host Names'
    • [mydomain].com for the Virtual Host
    • checked 'Start FTP site automatically'
    • Selected 'Allow SSL'
    • Selected 'Not Selected' for 'SSL Certificate'
  • Clicked 'Next'
    • Set Authentication to 'Basic'
    • Set 'Allow acces to:' to 'Specified Users' and 'newFTP'
    • Set permissions to 'read' and 'write'

Now when I try to login with ftp from the command line I get:

Connected to [mydomain].com.
220 Microsoft FTP Service
User ([mydomain].com:(none)): newFTP
331 Password required for newFTP.
Password:
530-User cannot log in, home directory inaccessible.
 Win32 error:   Access is denied.
 Error details: Authorization rules denied the access.
530 End
Login failed.
1

Double check that newFTP has read/write access to the ftp root folder (NTFS permissions on disk). Additionally, a couple of the user isolation modes require that the user also be granted 'list permissions' access to the root of the site.

There is a minor bug that may catch you with the authorization too. Just for testing, open that wide open. Once you get it working then lock it down again.

1

I ran into the same issue. I set it all up correctly with our domain etc. Here's a trick I found, not sure if it pertains to this: When you go to add authorization rules for each user or a group of users enter in the users with no spaces eg. user1,user2,user3 I did that and Viola! It worked! Apparently IIS isn't smart enough to ignore spaces.

0

I have no experience with ftp on iis7, but its been 16 hours, so here is my guess. Make sure that newftp user have access to the directory that the web site is installed in. I whould also make sure that there is no home directory configured in this user account.

0

I was struggling with the same problem for about 5 hours today. I'd suggest trying this method http://learn.iis.net/page.aspx/305/configuring-ftp-75-user-isolation/ and to turn off the firewall until you get it working. Port 21 open alone doesn't allow directory listing. Or if you can't turn off the firewall, connect to localhost on the FTP server machine. It worked in the end.

0

I just spent an hour chasing the same error message. In my case I wasn't looking properly at the Edit Allow Authorization Rule dialog and didn't notice that I'd put a Windows group name in the "Specified users:" field. Put it in the right field, all fixed.

Moral of the story: be very clear on which field you're putting your user/group into because IIS certainly doesn't bother validating it.

0

Another cause of this error can be the use of FTP IPv4 Address and Domain Restrictions.

If your IIS FTP Site, or one of its parents including the Default site, is using IPv4 Address Restrictions then you'll need to ensure that your IP address is allowed.

I had this same issue you've described, with the exact same Error returned to FileZilla. Here's how I fixed it:

  1. Open the IIS Manager
  2. Click on the Sites > Default FTP Site settings
  3. Open FTP IPv4 Address and Domain Restrictions
  4. Ask Google what is my ip
  5. Add your public IP address to the allowed list under FTP IPv4 Address and Domain Restrictions
  6. Open Services from the Start Menu
  7. Find the Microsoft FTP Service in the Started Services list
  8. Restart the Microsoft FTP Service

IIS Manager FTP IPv4 Address and Domain Restrictions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.