1

I have a windows 2008 R2 server with RRAS installed. I need it to make a demand dial connection to a remote VPN server. The type is PPTP.

What I've do so far:

  1. Installed RRAS. In the properties area I've enabled it to be an IPv4 router with LAN and demand-dial routing turned on. Under IPv4, it's set to enable IPv4 forwarding.

  2. I used the Demand-Dial interface wizard.

    • Connection Type: VPN
    • VPN type: PPTP
    • remote vpn server DNS name entered
    • Under Protocols, only "Route IP packets on this interface" is selected
    • On static routes, I put the specific internal IP address on the other side I need (192.168.x.x) with a net mask of 255.255.255.255 and metric of 1.
    • I entered the username/password etc.

When I click connect I get the following message:

An error occurred during connection of the interface. A connection the the remote computer could not be established. You might need to change the network settings for this connection.

The application event log shows 5 events which includes one that says (#20224):

The link to the remote access server has been established by user SYSTEM.

Immediately after that is one that contains a message saying (#20227):

The user SYSTEM dialed a connection named xxx which has failed. The error code returned on failure is 720.

The event numbers for all 5, in time order, are 20221, 20222, 20223, 20224 and 20227

The system event log shows an event 20167 which says:

No IP address is available to hand out to the dial-in client.

==================

Now, I can connect to that remote VPN server if I use a different computer running Windows 7 with the "set up a new connection" piece.

I'm not sure what else to do here.

1

Wow. I've been working on this problem off and on for 3 weeks.. and, of course, solved it after posting here.

In the RRAS server properties, General tab, I checked the IPv4 Remote Access Server setting under Enable this computer as a. This was not automatically checked during the wizard setup for the RRAS server. I figured it was only supposed to be checked if the server was actually acting like a RAS server instead of just as a router.

Also, I created a static address pool on the IPv4 tab. This address pool was there before, but I found that if I remove it then I'll get the exact same error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.